summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-06-10 07:42:38 +0200
committerRemi Collet <fedora@famillecollet.com>2012-06-10 07:42:38 +0200
commit5dcc8d0b7820ec1f0f489457ecf8b2265bfd16a0 (patch)
treeeeb04aa9dde72eb3d985b2ae43c07bf3eae16bc4
php-symfony2-CssSelector: import from rawhide
-rw-r--r--Makefile4
-rw-r--r--php-symfony2-CssSelector.spec104
2 files changed, 108 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-symfony2-CssSelector.spec b/php-symfony2-CssSelector.spec
new file mode 100644
index 0000000..9ef3c80
--- /dev/null
+++ b/php-symfony2-CssSelector.spec
@@ -0,0 +1,104 @@
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_channel pear.symfony.com
+%global pear_name %(echo %{name} | sed -e 's/^php-symfony2-//' -e 's/-/_/g')
+
+Name: php-symfony2-CssSelector
+Version: 2.0.15
+Release: 1%{?dist}
+Summary: Symfony2 %{pear_name} Component
+
+Group: Development/Libraries
+License: MIT
+URL: http://symfony.com/doc/current/components/css_selector.html
+Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+
+BuildArch: noarch
+BuildRequires: php-pear(PEAR)
+BuildRequires: php-channel(%{pear_channel})
+
+Requires: php-common >= 5.3.2
+Requires: php-mbstring
+Requires: php-pcre
+Requires: php-pear(PEAR)
+Requires: php-channel(%{pear_channel})
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+
+Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
+
+%description
+The CssSelector Component converts CSS selectors to XPath expressions.
+
+
+%prep
+%setup -q -c
+# package.xml is version 2.0
+mv package.xml %{pear_name}-%{version}/%{name}.xml
+
+
+%build
+# Empty build section, most likely nothing required.
+
+
+%install
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+
+# Clean up unnecessary files
+rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+
+# Install XML package description
+mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
+install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ %{pear_channel}/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%doc %{pear_docdir}/%{pear_name}
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Symfony/Component/%{pear_name}
+%dir %{pear_phpdir}/Symfony/Component
+%dir %{pear_phpdir}/Symfony
+
+
+%changelog
+* Wed May 30 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 2.0.15-1
+- Updated to upstream version 2.0.15
+- Removed "BuildRequires: php-pear >= 1:1.4.9-1.2"
+- Updated %%prep section
+- Removed cleaning buildroot from %%install section
+- Removed documentation move from %%install section (fixed upstream)
+- Removed %%clean section
+- Updated %%doc in %%files section
+
+* Sun May 20 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 2.0.14-3
+- Moved documentation to correct location
+
+* Sun May 20 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 2.0.14-2
+- Removed BuildRoot
+- Changed php require to php-common
+- Added the following requires based on phpci results:
+ php-mbstring, php-pcre
+- Removed %%defattr from %%files section
+
+* Fri May 18 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 2.0.14-1
+- Updated to upstream version 2.0.14
+- %%global instead of %%define
+- Removed unnecessary cd from %%build section
+
+* Wed May 2 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 2.0.13-1
+- Updated to upstream version 2.0.13
+
+* Sat Apr 21 2012 Shawn Iwinski <shawn.iwinski@gmail.com> 2.0.12-1
+- Initial package