summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-10-06 15:28:48 +0200
committerRemi Collet <fedora@famillecollet.com>2012-10-06 15:28:48 +0200
commit57ebde90f109113f04a1a52d774c9cdf62e112af (patch)
tree00917de7b4235a0250baeeafcf3abd1109a22ebd
parentb69f563c8469724cec5aef1f3164ccf51c2eea96 (diff)
php-symfony2-Console 2.1.2
-rw-r--r--php-symfony2-Console.spec20
1 files changed, 18 insertions, 2 deletions
diff --git a/php-symfony2-Console.spec b/php-symfony2-Console.spec
index baa77d9..47aaffa 100644
--- a/php-symfony2-Console.spec
+++ b/php-symfony2-Console.spec
@@ -1,10 +1,11 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
%global pear_channel pear.symfony.com
%global pear_name %(echo %{name} | sed -e 's/^php-symfony2-//' -e 's/-/_/g')
Name: php-symfony2-Console
-Version: 2.0.17
+Version: 2.1.2
Release: 1%{?dist}
Summary: Symfony2 %{pear_name} Component
@@ -17,6 +18,8 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-pear(PEAR)
BuildRequires: php-channel(%{pear_channel})
+# For tests
+BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
Requires: php-common >= 5.3.2
Requires: php-pear(PEAR)
@@ -44,6 +47,13 @@ other batch jobs.
%prep
%setup -q -c
+
+# Hum...
+sed -e '/CHANGELOG.md/s/role="php"/role="doc"/' \
+ -e '/phpunit.xml.dist/s/role="php"/role="test"/' \
+ -e '/Tests/s/role="php"/role="test"/' \
+ -i package.xml
+
# package.xml is version 2.0
mv package.xml %{pear_name}-%{version}/%{name}.xml
@@ -57,13 +67,18 @@ cd %{pear_name}-%{version}
%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_phpdir}/.??*
+rm -rf $RPM_BUILD_ROOT%{pear_metadir}/.??*
# Install XML package description
mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+%check
+cd %{pear_name}-%{version}/Symfony/Component/%{pear_name}/Tests
+phpunit --bootstrap bootstrap.php .
+
+
%post
%{__pear} install --nodeps --soft --force --register-only \
%{pear_xmldir}/%{name}.xml >/dev/null || :
@@ -83,6 +98,7 @@ fi
%dir %{pear_phpdir}/Symfony
%dir %{pear_phpdir}/Symfony/Component
%{pear_phpdir}/Symfony/Component/%{pear_name}
+ %{pear_testdir}/%{pear_name}
%changelog