summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-04-06 15:52:58 +0200
committerRemi Collet <fedora@famillecollet.com>2013-04-06 15:52:58 +0200
commitacda825f7a368ef0c22e0078b8428e30f13b0e20 (patch)
tree3873892390282f0370315bf8db5b05e1eed613cc
parent4a2fb6823951534953f56eb85c2704b8394e176a (diff)
php-symfony2-Config: sync with rawhide
-rw-r--r--php-symfony2-Config.spec73
1 files changed, 59 insertions, 14 deletions
diff --git a/php-symfony2-Config.spec b/php-symfony2-Config.spec
index 408a30c..c8bf432 100644
--- a/php-symfony2-Config.spec
+++ b/php-symfony2-Config.spec
@@ -1,10 +1,10 @@
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
%global pear_channel pear.symfony.com
-%global pear_name %(echo %{name} | sed -e 's/^php-symfony2-//' -e 's/-/_/g')
+%global pear_name Config
%global php_min_ver 5.3.3
-Name: php-symfony2-Config
+Name: php-symfony2-%{pear_name}
Version: 2.2.0
Release: 1%{?dist}
Summary: Symfony2 %{pear_name} Component
@@ -16,15 +16,18 @@ Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
+
BuildRequires: php-pear(PEAR)
BuildRequires: php-channel(%{pear_channel})
-# Test requires
+# For tests
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
-# Test requires: phpci
+# For tests: phpci
BuildRequires: php-ctype
BuildRequires: php-date
+BuildRequires: php-dom
BuildRequires: php-json
+BuildRequires: php-libxml
BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
@@ -34,10 +37,12 @@ Requires: php-pear(PEAR)
Requires: php-channel(%{pear_channel})
Requires(post): %{__pear}
Requires(postun): %{__pear}
-# phpci requires
+# phpci
Requires: php-ctype
Requires: php-date
+Requires: php-dom
Requires: php-json
+Requires: php-libxml
Requires: php-pcre
Requires: php-reflection
Requires: php-spl
@@ -53,15 +58,46 @@ may be (Yaml, XML, INI files, or for instance a database).
%prep
%setup -q -c
+# Create PHPUnit autoloader
+( cat <<'PHPUNIT_AUTOLOADER'
+<?php
+
+# This file was created by RPM packaging and is not part of the original
+# Symfony2 %{pear_name} PEAR package.
+
+set_include_path(
+ '%{pear_phpdir}'.PATH_SEPARATOR.
+ '%{pear_testdir}/%{pear_name}'.PATH_SEPARATOR.
+ get_include_path()
+);
+
+spl_autoload_register(function ($class) {
+ if ('\\' == $class[0]) {
+ $class = substr($class, 1);
+ }
+
+ $file = str_replace('\\', '/', $class).'.php';
+ @include $file;
+});
+PHPUNIT_AUTOLOADER
+) > phpunit.autoloader.php
+
+# Update PHPUnit config
+sed -e 's#vendor/autoload.php#./phpunit.autoloader.php#' \
+ -i %{pear_name}-%{version}/Symfony/Component/%{pear_name}/phpunit.xml.dist
+
# Modify PEAR package.xml file:
+# - Remove .gitattributes file
# - Remove .gitignore file
# - Change role from "php" to "doc" for CHANGELOG.md file
# - Change role from "php" to "test" for all test files
-# - Remove md5sum from bootsrap.php file since it was patched
-sed -e '/\.gitignore/d' \
+# - Remove md5sum from phpunit.xml.dist file since it was updated
+sed -e '/\.gitattributes/d' \
+ -e '/\.gitignore/d' \
-e '/CHANGELOG.md/s/role="php"/role="doc"/' \
- -e '/phpunit.xml.dist/s/role="php"/role="test"/' \
-e '/Tests/s/role="php"/role="test"/' \
+ -e '/phpunit.xml.dist/s/role="php"/role="test"/' \
+ -e '/phpunit.xml.dist/s/md5sum="[^"]*"\s*//' \
-i package.xml
# package.xml is version 2.0
@@ -83,17 +119,17 @@ rm -rf %{buildroot}%{pear_metadir}/.??*
mkdir -p %{buildroot}%{pear_xmldir}
install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
-sed -e '/bootstrap/s:vendor/autoload.php:%{pear_phpdir}/Symfony/Component/%{pear_name}/autoloader.php:' \
- %{buildroot}%{pear_testdir}/%{pear_name}/Symfony/Component/%{pear_name}/phpunit.xml.dist \
- > %{buildroot}%{pear_testdir}/%{pear_name}/Symfony/Component/%{pear_name}/phpunit.xml
+# Install PHPUnit autoloader
+install -pm 0644 ../phpunit.autoloader.php \
+ %{buildroot}/%{pear_testdir}/%{pear_name}/Symfony/Component/%{pear_name}/
%check
cd %{pear_name}-%{version}/Symfony/Component/%{pear_name}
-sed -e '/bootstrap/s:vendor/autoload.php:autoloader.php:' \
- phpunit.xml.dist > phpunit.xml
-%{_bindir}/phpunit -d date.timezone=UTC
+sed 's#./phpunit.autoloader.php#./autoloader.php#' -i phpunit.xml.dist
+
+%{_bindir}/phpunit -d date.timezone="UTC"
%post
@@ -117,7 +153,16 @@ fi
%{pear_phpdir}/Symfony/Component/%{pear_name}
%{pear_testdir}/%{pear_name}
+
%changelog
+* Wed Mar 13 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 2.2.0-1
+- Updated to 2.2.0
+- Removed tests' bootstrap patch
+- Added php-dom and php-libxml requires
+
+* Sun Mar 03 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 2.1.8-2
+- Fixed default timezone for tests
+
* Tue Mar 05 2013 Remi Collet <remi@fedoraproject.org> - 2.2.0-1
- Update to 2.2.0