summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-04-06 17:04:23 +0200
committerRemi Collet <fedora@famillecollet.com>2013-04-06 17:04:23 +0200
commitbb6da35755663db632c83b9b25b7382e3b6881e8 (patch)
tree8601176b31405fef695ff5697b6a890c555a44ba
parent8dc2a1c5035ca2f35a1713826ed95d4fe0d0dc4c (diff)
php-symfony2-BrowserKit: sync with rawhide
-rw-r--r--php-symfony2-BrowserKit.spec74
1 files changed, 58 insertions, 16 deletions
diff --git a/php-symfony2-BrowserKit.spec b/php-symfony2-BrowserKit.spec
index db9ac3b..5cb6780 100644
--- a/php-symfony2-BrowserKit.spec
+++ b/php-symfony2-BrowserKit.spec
@@ -1,30 +1,34 @@
%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
%global pear_channel pear.symfony.com
-%global pear_name %(echo %{name} | sed -e 's/^php-symfony2-//' -e 's/-/_/g')
+%global pear_name BrowserKit
%global php_min_ver 5.3.3
-Name: php-symfony2-BrowserKit
+Name: php-symfony2-%{pear_name}
Version: 2.2.0
Release: 1%{?dist}
Summary: Symfony2 %{pear_name} Component
Group: Development/Libraries
License: MIT
-URL: http://symfony.com/components
+URL: http://symfony.com/doc/current/components/index.html
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
+
BuildRequires: php-pear(PEAR)
BuildRequires: php-channel(%{pear_channel})
-# Test requires
+# For tests
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-pear(pear.phpunit.de/PHPUnit)
BuildRequires: php-pear(%{pear_channel}/CssSelector) >= 2.2.0
+BuildRequires: php-pear(%{pear_channel}/CssSelector) < 2.3.0
BuildRequires: php-pear(%{pear_channel}/DomCrawler) >= 2.2.0
+BuildRequires: php-pear(%{pear_channel}/DomCrawler) < 2.3.0
BuildRequires: php-pear(%{pear_channel}/Process) >= 2.2.0
-# Test requires: phpci
+BuildRequires: php-pear(%{pear_channel}/Process) < 2.3.0
+# For tests: phpci
BuildRequires: php-date
BuildRequires: php-pcre
BuildRequires: php-reflection
@@ -34,15 +38,17 @@ Requires: php(language) >= %{php_min_ver}
Requires: php-pear(PEAR)
Requires: php-channel(%{pear_channel})
Requires: php-pear(%{pear_channel}/DomCrawler) >= 2.2.0
+Requires: php-pear(%{pear_channel}/DomCrawler) < 2.3.0
Requires(post): %{__pear}
Requires(postun): %{__pear}
-# phpci requires
+# phpci
Requires: php-date
Requires: php-pcre
Requires: php-reflection
Requires: php-spl
-# Optional requires
+# Optional
Requires: php-pear(%{pear_channel}/Process) >= 2.2.0
+Requires: php-pear(%{pear_channel}/Process) < 2.3.0
Provides: php-pear(%{pear_channel}/%{pear_name}) = %{version}
@@ -56,15 +62,46 @@ The component only provides an abstract client and does not provide any
%prep
%setup -q -c
+# Create PHPUnit autoloader
+( cat <<'PHPUNIT_AUTOLOADER'
+<?php
+
+# This file was created by RPM packaging and is not part of the original
+# Symfony2 %{pear_name} PEAR package.
+
+set_include_path(
+ '%{pear_phpdir}'.PATH_SEPARATOR.
+ '%{pear_testdir}/%{pear_name}'.PATH_SEPARATOR.
+ get_include_path()
+);
+
+spl_autoload_register(function ($class) {
+ if ('\\' == $class[0]) {
+ $class = substr($class, 1);
+ }
+
+ $file = str_replace('\\', '/', $class).'.php';
+ @include $file;
+});
+PHPUNIT_AUTOLOADER
+) > phpunit.autoloader.php
+
+# Update PHPUnit config
+sed -e 's#vendor/autoload.php#./phpunit.autoloader.php#' \
+ -i %{pear_name}-%{version}/Symfony/Component/%{pear_name}/phpunit.xml.dist
+
# Modify PEAR package.xml file:
+# - Remove .gitattributes file
# - Remove .gitignore file
# - Change role from "php" to "doc" for CHANGELOG.md file
# - Change role from "php" to "test" for all test files
-# - Remove md5sum from bootsrap.php file since it was patched
-sed -e '/\.gitignore/d' \
+# - Remove md5sum from phpunit.xml.dist file since it was updated
+sed -e '/\.gitattributes/d' \
+ -e '/\.gitignore/d' \
-e '/CHANGELOG.md/s/role="php"/role="doc"/' \
- -e '/phpunit.xml.dist/s/role="php"/role="test"/' \
-e '/Tests/s/role="php"/role="test"/' \
+ -e '/phpunit.xml.dist/s/role="php"/role="test"/' \
+ -e '/phpunit.xml.dist/s/md5sum="[^"]*"\s*//' \
-i package.xml
# package.xml is version 2.0
@@ -86,16 +123,17 @@ rm -rf %{buildroot}%{pear_metadir}/.??*
mkdir -p %{buildroot}%{pear_xmldir}
install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
-sed -e '/bootstrap/s:vendor/autoload.php:%{pear_phpdir}/Symfony/Component/%{pear_name}/autoloader.php:' \
- %{buildroot}%{pear_testdir}/%{pear_name}/Symfony/Component/%{pear_name}/phpunit.xml.dist \
- > %{buildroot}%{pear_testdir}/%{pear_name}/Symfony/Component/%{pear_name}/phpunit.xml
+# Install PHPUnit autoloader
+install -pm 0644 ../phpunit.autoloader.php \
+ %{buildroot}/%{pear_testdir}/%{pear_name}/Symfony/Component/%{pear_name}/
%check
cd %{pear_name}-%{version}/Symfony/Component/%{pear_name}
-sed -e '/bootstrap/s:vendor/autoload.php:autoloader.php:' \
- phpunit.xml.dist > phpunit.xml
-%{_bindir}/phpunit -d date.timezone=UTC
+
+sed 's#./phpunit.autoloader.php#./autoloader.php#' -i phpunit.xml.dist
+
+%{_bindir}/phpunit -d date.timezone="UTC"
%post
@@ -119,6 +157,10 @@ fi
%changelog
+* Wed Mar 13 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 2.2.0-1
+- Updated to 2.2.0
+- Removed tests' bootstrap patch
+
* Wed Mar 06 2013 Remi Collet <remi@fedoraproject.org> - 2.2.0-1
- Update to 2.2.0