summaryrefslogtreecommitdiffstats
path: root/php-symfony4.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-03-29 11:21:03 +0200
committerRemi Collet <remi@remirepo.net>2021-03-29 11:21:03 +0200
commitc641203a7211ebdf386b3cfba411311934378fab (patch)
tree681700a2d94ac961e0edd6bc535776ef89033aa5 /php-symfony4.spec
parentfa7b7431688acdc5445f0d4391ac8f1fba0f7a66 (diff)
update to 4.4.21
allow egulias/email-validator v3
Diffstat (limited to 'php-symfony4.spec')
-rw-r--r--php-symfony4.spec26
1 files changed, 15 insertions, 11 deletions
diff --git a/php-symfony4.spec b/php-symfony4.spec
index f5a5102..233d607 100644
--- a/php-symfony4.spec
+++ b/php-symfony4.spec
@@ -13,8 +13,8 @@
%global github_owner symfony
%global github_name symfony
-%global github_version 4.4.20
-%global github_commit fb90227d34531b06c01f1450c0c490fbf3fd7a8e
+%global github_version 4.4.21
+%global github_commit 0139b7a74507b39b1ace35fa5544be5aee1dca5f
%global github_short %(c=%{github_commit}; echo ${c:0:7})
%global composer_vendor symfony
@@ -54,9 +54,9 @@
# "doctrine/orm": "^2.6.3"
%global doctrine_orm_min_ver 2.6.3
%global doctrine_orm_max_ver 3.0
-# "egulias/email-validator": "^2.1.10"
+# "egulias/email-validator": "^2.1.10|^3.1"
%global email_validator_min_ver 2.1.10
-%global email_validator_max_ver 3.0
+%global email_validator_max_ver 4
# "guzzlehttp/promises": "^1.3.1"
%global guzzlehttp_promises_min_ver 1.3.1
%global guzzlehttp_promises_max_ver 2
@@ -121,8 +121,8 @@
%global psr_http_client_min_ver 1.0
%global psr_http_client_max_ver 2
-# Build using "--without tests" to disable tests
-%global with_tests 0%{?_with_tests:1}
+# Build using "--with tests" to enable tests
+%bcond_with tests
%global with_sensio_framework_extra_bundle 0
@@ -281,10 +281,10 @@ BuildRequires: php-sysvsem
BuildRequires: php-tokenizer
BuildRequires: php-xml
BuildRequires: php-xmlreader
-## Autoloader
-BuildRequires: php-fedora-autoloader-devel
# Conflicts
BuildConflicts: php-composer(phpdocumentor/type-resolver) < 0.3.0
+## Autoloader
+BuildRequires: php-fedora-autoloader-devel
# Bridges
Requires: php-composer(%{composer_vendor}/doctrine-bridge) = %{version}
@@ -2322,7 +2322,7 @@ AUTOLOAD
done
: Create dummy Composer autoloader for tests
-%if %{with_tests}
+%if %{with tests}
pushd src/Symfony
cat <<COMPOSER_JSON | tee composer.json
{
@@ -2356,7 +2356,7 @@ ln -s %{name}-common-%{version} %{buildroot}%{_docdir}/%{name}-%{version}
%check
-%if %{with_tests}
+%if %{with tests}
: Ensure TZ is set
cp -pf %{_sysconfdir}/php.ini .
echo "date.timezone=UTC" >> php.ini
@@ -2437,7 +2437,7 @@ exit $RET
%{symfony4_dir}/Bundle/autoload.php
%dir %{symfony4_dir}/Component
%{symfony4_dir}/Component/autoload.php
-%if %{with_tests}
+%if %{with tests}
%exclude %{symfony4_dir}/vendor
%endif
@@ -3303,6 +3303,10 @@ exit $RET
# ##############################################################################
%changelog
+* Mon Mar 29 2021 Remi Collet <remi@remirepo.net> - 4.4.21-1
+- update to 4.4.21
+- allow egulias/email-validator v3
+
* Mon Mar 8 2021 Remi Collet <remi@remirepo.net> - 4.4.20-1
- update to 4.4.20