summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-05-19 16:54:36 +0200
committerRemi Collet <remi@remirepo.net>2021-05-19 16:54:36 +0200
commitc113dd4e2d060a57d8790fd8cfe11432b188a244 (patch)
tree950fc77c0296c60988cd154b946b1de65db0ec26
parent7d3dad72f01ea09d04e8345396809b450132e718 (diff)
update to 4.4.24
-rw-r--r--composer.json2
-rwxr-xr-xphp-symfony4-generate-autoloaders.php5
-rw-r--r--php-symfony4.spec11
-rw-r--r--src/Symfony/Bridge/Doctrine/composer.json1
-rw-r--r--src/Symfony/Bundle/FrameworkBundle/composer.json4
-rw-r--r--src/Symfony/Bundle/TwigBundle/composer.json2
-rw-r--r--src/Symfony/Component/Cache/composer.json2
-rw-r--r--src/Symfony/Component/Serializer/composer.json4
-rw-r--r--src/Symfony/Component/Validator/composer.json2
9 files changed, 18 insertions, 15 deletions
diff --git a/composer.json b/composer.json
index 737f767..39a35f3 100644
--- a/composer.json
+++ b/composer.json
@@ -119,7 +119,7 @@
"cache/integration-tests": "dev-master",
"composer/package-versions-deprecated": "^1.8",
"doctrine/annotations": "^1.10.4",
- "doctrine/cache": "~1.6",
+ "doctrine/cache": "^1.6|^2.0",
"doctrine/collections": "~1.0",
"doctrine/data-fixtures": "^1.1",
"doctrine/dbal": "^2.6|^3.0",
diff --git a/php-symfony4-generate-autoloaders.php b/php-symfony4-generate-autoloaders.php
index ca155fe..682b508 100755
--- a/php-symfony4-generate-autoloaders.php
+++ b/php-symfony4-generate-autoloaders.php
@@ -42,7 +42,10 @@ final class AutoloadGenerator {
],
'doctrine/cache' => [
'prefix' => 'FEDORA_SYMFONY4_PHP_DIR',
- 'path' => 'Doctrine/Common/Cache/autoload.php',
+ 'path' => [
+ 'Doctrine/Common/Cache2/autoload.php',
+ 'Doctrine/Common/Cache/autoload.php',
+ ],
],
'doctrine/collections' => [
'prefix' => 'FEDORA_SYMFONY4_PHP_DIR',
diff --git a/php-symfony4.spec b/php-symfony4.spec
index 451ba8b..3d6829d 100644
--- a/php-symfony4.spec
+++ b/php-symfony4.spec
@@ -13,8 +13,8 @@
%global github_owner symfony
%global github_name symfony
-%global github_version 4.4.23
-%global github_commit bb7ec823d2ea5a77c83a11739fc38f62e2b7999c
+%global github_version 4.4.24
+%global github_commit 854af7600a6249c34bdbf4120e078aef6ece660e
%global github_short %(c=%{github_commit}; echo ${c:0:7})
%global composer_vendor symfony
@@ -29,9 +29,9 @@
# "doctrine/annotations": "~1.10.4"
%global doctrine_annotations_min_ver 1.10.4
%global doctrine_annotations_max_ver 2.0
-# "doctrine/cache": "~1.6"
+# "doctrine/cache": "^1.6|^2.0"
%global doctrine_cache_min_ver 1.6
-%global doctrine_cache_max_ver 2.0
+%global doctrine_cache_max_ver 3
# "doctrine/collections": "~1.0"
%global doctrine_collections_min_ver 1.0
%global doctrine_collections_max_ver 2
@@ -3303,6 +3303,9 @@ exit $RET
# ##############################################################################
%changelog
+* Wed May 19 2021 Remi Collet <remi@remirepo.net> - 4.4.24-1
+- update to 4.4.24
+
* Mon May 17 2021 Remi Collet <remi@remirepo.net> - 4.4.23-1
- update to 4.4.23
diff --git a/src/Symfony/Bridge/Doctrine/composer.json b/src/Symfony/Bridge/Doctrine/composer.json
index 68fbcef..17a83e7 100644
--- a/src/Symfony/Bridge/Doctrine/composer.json
+++ b/src/Symfony/Bridge/Doctrine/composer.json
@@ -40,7 +40,6 @@
"symfony/var-dumper": "^3.4|^4.0|^5.0",
"symfony/translation": "^3.4|^4.0|^5.0",
"doctrine/annotations": "^1.10.4",
- "doctrine/cache": "~1.6",
"doctrine/collections": "~1.0",
"doctrine/data-fixtures": "^1.1",
"doctrine/dbal": "^2.6|^3.0",
diff --git a/src/Symfony/Bundle/FrameworkBundle/composer.json b/src/Symfony/Bundle/FrameworkBundle/composer.json
index f262983..efa69d2 100644
--- a/src/Symfony/Bundle/FrameworkBundle/composer.json
+++ b/src/Symfony/Bundle/FrameworkBundle/composer.json
@@ -19,7 +19,7 @@
"php": ">=7.1.3",
"ext-xml": "*",
"symfony/cache": "^4.4|^5.0",
- "symfony/config": "^4.3.4|^5.0",
+ "symfony/config": "^4.4.11|~5.0.11|^5.1.3",
"symfony/dependency-injection": "^4.4.1|^5.0.1",
"symfony/error-handler": "^4.4.1|^5.0.1",
"symfony/http-foundation": "^4.4|^5.0",
@@ -31,7 +31,7 @@
},
"require-dev": {
"doctrine/annotations": "^1.10.4",
- "doctrine/cache": "~1.0",
+ "doctrine/cache": "^1.0|^2.0",
"doctrine/persistence": "^1.3|^2.0",
"paragonie/sodium_compat": "^1.8",
"symfony/asset": "^3.4|^4.0|^5.0",
diff --git a/src/Symfony/Bundle/TwigBundle/composer.json b/src/Symfony/Bundle/TwigBundle/composer.json
index 57cf455..0178473 100644
--- a/src/Symfony/Bundle/TwigBundle/composer.json
+++ b/src/Symfony/Bundle/TwigBundle/composer.json
@@ -37,7 +37,7 @@
"symfony/framework-bundle": "^4.4|^5.0",
"symfony/web-link": "^3.4|^4.0|^5.0",
"doctrine/annotations": "^1.10.4",
- "doctrine/cache": "~1.0"
+ "doctrine/cache": "^1.0|^2.0"
},
"conflict": {
"symfony/dependency-injection": "<4.1",
diff --git a/src/Symfony/Component/Cache/composer.json b/src/Symfony/Component/Cache/composer.json
index 87a2607..209d758 100644
--- a/src/Symfony/Component/Cache/composer.json
+++ b/src/Symfony/Component/Cache/composer.json
@@ -30,7 +30,7 @@
},
"require-dev": {
"cache/integration-tests": "dev-master",
- "doctrine/cache": "^1.6",
+ "doctrine/cache": "^1.6|^2.0",
"doctrine/dbal": "^2.6|^3.0",
"predis/predis": "^1.1",
"psr/simple-cache": "^1.0",
diff --git a/src/Symfony/Component/Serializer/composer.json b/src/Symfony/Component/Serializer/composer.json
index 2cf3920..075896e 100644
--- a/src/Symfony/Component/Serializer/composer.json
+++ b/src/Symfony/Component/Serializer/composer.json
@@ -21,7 +21,6 @@
},
"require-dev": {
"doctrine/annotations": "^1.10.4",
- "doctrine/cache": "~1.0",
"phpdocumentor/reflection-docblock": "^3.2|^4.0|^5.0",
"symfony/cache": "^3.4|^4.0|^5.0",
"symfony/config": "^3.4|^4.0|^5.0",
@@ -49,8 +48,7 @@
"symfony/config": "For using the XML mapping loader.",
"symfony/property-access": "For using the ObjectNormalizer.",
"symfony/http-foundation": "For using a MIME type guesser within the DataUriNormalizer.",
- "doctrine/annotations": "For using the annotation mapping. You will also need doctrine/cache.",
- "doctrine/cache": "For using the default cached annotation reader and metadata cache."
+ "doctrine/annotations": "For using the annotation mapping."
},
"autoload": {
"psr-4": { "Symfony\\Component\\Serializer\\": "" },
diff --git a/src/Symfony/Component/Validator/composer.json b/src/Symfony/Component/Validator/composer.json
index c9cbe68..e32a72b 100644
--- a/src/Symfony/Component/Validator/composer.json
+++ b/src/Symfony/Component/Validator/composer.json
@@ -36,7 +36,7 @@
"symfony/property-info": "^3.4|^4.0|^5.0",
"symfony/translation": "^4.2",
"doctrine/annotations": "^1.10.4",
- "doctrine/cache": "~1.0",
+ "doctrine/cache": "^1.0|^2.0",
"egulias/email-validator": "^2.1.10|^3"
},
"conflict": {