summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-11-23 08:49:28 +0100
committerRemi Collet <remi@php.net>2021-11-23 08:49:28 +0100
commit46f440f33d857714f63f09d128bec7f7b910e6aa (patch)
treeb5268da37158da3699374c049c50b9ede1a7b132
parentc70d4d1c8457d4f71e577196a731949052af8c77 (diff)
update to 4.4.34
allow psr/simple-cache v2
-rw-r--r--composer.json4
-rwxr-xr-xphp-symfony4-generate-autoloaders.php5
-rw-r--r--php-symfony4.spec15
-rw-r--r--src/Symfony/Component/Cache/composer.json4
-rw-r--r--src/Symfony/Component/Mailer/Bridge/Google/composer.json3
5 files changed, 19 insertions, 12 deletions
diff --git a/composer.json b/composer.json
index 1e73439..5388530 100644
--- a/composer.json
+++ b/composer.json
@@ -24,7 +24,7 @@
"psr/http-client-implementation": "1.0",
"psr/link-implementation": "1.0",
"psr/log-implementation": "1.0|2.0",
- "psr/simple-cache-implementation": "1.0",
+ "psr/simple-cache-implementation": "1.0|2.0",
"symfony/cache-implementation": "1.0|2.0",
"symfony/event-dispatcher-implementation": "1.1",
"symfony/http-client-implementation": "1.1|2.0",
@@ -133,7 +133,7 @@
"php-http/httplug": "^1.0|^2.0",
"predis/predis": "~1.1",
"psr/http-client": "^1.0",
- "psr/simple-cache": "^1.0",
+ "psr/simple-cache": "^1.0|^2.0",
"egulias/email-validator": "^2.1.10|^3.1",
"symfony/phpunit-bridge": "^5.2",
"symfony/security-acl": "~2.8|~3.0",
diff --git a/php-symfony4-generate-autoloaders.php b/php-symfony4-generate-autoloaders.php
index 05af3c1..8955b93 100755
--- a/php-symfony4-generate-autoloaders.php
+++ b/php-symfony4-generate-autoloaders.php
@@ -157,7 +157,10 @@ final class AutoloadGenerator {
],
'psr/simple-cache' => [
'prefix' => 'FEDORA_SYMFONY4_PHP_DIR',
- 'path' => 'Psr/SimpleCache/autoload.php',
+ 'path' => [
+ 'Psr/SimpleCache2/autoload.php',
+ 'Psr/SimpleCache/autoload.php',
+ ],
],
'symfony/asset' => [
'prefix' => 'FEDORA_SYMFONY4_DIR',
diff --git a/php-symfony4.spec b/php-symfony4.spec
index bedfffc..4790e45 100644
--- a/php-symfony4.spec
+++ b/php-symfony4.spec
@@ -13,8 +13,8 @@
%global github_owner symfony
%global github_name symfony
-%global github_version 4.4.33
-%global github_commit dfaf56541a8d44004dc37dc9422340b1f056721d
+%global github_version 4.4.34
+%global github_commit f67512f42dc625077573d68d96df987dc4886ba7
%global github_short %(c=%{github_commit}; echo ${c:0:7})
%global composer_vendor symfony
@@ -85,9 +85,9 @@
%global psr_log_min_ver 1.0
# v2 is not yet packaged
%global psr_log_max_ver 2.0
-# "psr/simple-cache": "^1.0"
+# "psr/simple-cache": "^1.0|^2.0"
%global psr_simple_cache_min_ver 1.0
-%global psr_simple_cache_max_ver 2.0
+%global psr_simple_cache_max_ver 3
# "symfony/polyfill-intl-ctype": "~1.8"
# "symfony/polyfill-intl-icu": "~1.0"
# "symfony/polyfill-intl-idn": "~1.10"
@@ -900,8 +900,11 @@ Requires: php-spl
# Composer
Provides: php-composer(%{composer_vendor}/cache) = %{version}
Provides: php-composer(psr/cache-implementation) = 1.0
+Provides: php-composer(psr/cache-implementation) = 2.0
Provides: php-composer(psr/simple-cache-implementation) = 1.0
+Provides: php-composer(psr/simple-cache-implementation) = 2.0
Provides: php-composer(%{composer_vendor}/cache-implementation) = 1.0
+Provides: php-composer(%{composer_vendor}/cache-implementation) = 2.0
%description cache
The Cache component provides an extended PSR-6 [1] implementation for adding
@@ -3312,6 +3315,10 @@ exit $RET
# ##############################################################################
%changelog
+* Tue Nov 23 2021 Remi Collet <remi@remirepo.net> - 4.4.34-1
+- update to 4.4.34
+- allow psr/simple-cache v2
+
* Fri Oct 29 2021 Remi Collet <remi@remirepo.net> - 4.4.33-1
- update to 4.4.33
diff --git a/src/Symfony/Component/Cache/composer.json b/src/Symfony/Component/Cache/composer.json
index 72bd68f..6ef5eac 100644
--- a/src/Symfony/Component/Cache/composer.json
+++ b/src/Symfony/Component/Cache/composer.json
@@ -17,7 +17,7 @@
],
"provide": {
"psr/cache-implementation": "1.0|2.0",
- "psr/simple-cache-implementation": "1.0",
+ "psr/simple-cache-implementation": "1.0|2.0",
"symfony/cache-implementation": "1.0|2.0"
},
"require": {
@@ -35,7 +35,7 @@
"doctrine/cache": "^1.6|^2.0",
"doctrine/dbal": "^2.7|^3.0",
"predis/predis": "^1.1",
- "psr/simple-cache": "^1.0",
+ "psr/simple-cache": "^1.0|^2.0",
"symfony/config": "^4.2|^5.0",
"symfony/dependency-injection": "^3.4|^4.1|^5.0",
"symfony/filesystem": "^4.4|^5.0",
diff --git a/src/Symfony/Component/Mailer/Bridge/Google/composer.json b/src/Symfony/Component/Mailer/Bridge/Google/composer.json
index a3fbd96..b7fd1ea 100644
--- a/src/Symfony/Component/Mailer/Bridge/Google/composer.json
+++ b/src/Symfony/Component/Mailer/Bridge/Google/composer.json
@@ -19,9 +19,6 @@
"php": ">=7.1.3",
"symfony/mailer": "^4.4|^5.0"
},
- "require-dev": {
- "symfony/http-client": "^4.3|^5.0"
- },
"autoload": {
"psr-4": { "Symfony\\Component\\Mailer\\Bridge\\Google\\": "" },
"exclude-from-classmap": [