summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-01-13 12:06:35 +0100
committerRemi Collet <remi@php.net>2022-01-13 12:06:35 +0100
commit1c176080c91d33e10f39ab07a1f6812a77fe3214 (patch)
tree793ccaaf35df6160913e5e5aebb9e9ad75cc8c91
parent3560f36bb024b18c8136c1789a3a4148f04607dd (diff)
cleanup more unneeded polyfillsHEADmaster
-rw-r--r--php-symfony4.spec17
1 files changed, 0 insertions, 17 deletions
diff --git a/php-symfony4.spec b/php-symfony4.spec
index a9ee2bf..d0e4b87 100644
--- a/php-symfony4.spec
+++ b/php-symfony4.spec
@@ -968,7 +968,6 @@ URL: http://symfony.com/doc/%{symfony4_doc_ver}/components/console.html
Requires: php-composer(%{composer_vendor}/debug) = %{version}
%if %{with_range_dependencies}
Requires:(php-composer(%{composer_vendor}/service-contracts) >= %{symfony_contracts_min_ver} with php-composer(%{composer_vendor}/service-contracts) < %{symfony_contracts_max_ver})
-Requires:(php-composer(%{composer_vendor}/polyfill-php73) >= %{symfony_polyfill_min_ver} with php-composer(%{composer_vendor}/polyfill-php73) < %{symfony_polyfill_max_ver})
# composer.json: optional
Suggests: php-composer(%{composer_vendor}/event-dispatcher)
Suggests: php-composer(%{composer_vendor}/lock)
@@ -977,8 +976,6 @@ Suggests: php-composer(psr/log)
%else
Requires: php-composer(%{composer_vendor}/service-contracts) < %{symfony_contracts_max_ver}
Requires: php-composer(%{composer_vendor}/service-contracts) >= %{symfony_contracts_min_ver}
-Requires: php-composer(%{composer_vendor}/polyfill-php73) < %{symfony_polyfill_max_ver}
-Requires: php-composer(%{composer_vendor}/polyfill-php73) >= %{symfony_polyfill_min_ver}
%endif
# phpcompatinfo for version 4.0.0-beta1
Requires: php-date
@@ -1355,7 +1352,6 @@ Requires: %{name}-common = %{version}-%{release}
Requires:(php-composer(guzzlehttp/promises) >= %{guzzlehttp_promises_min_ver} with php-composer(guzzlehttp/promises) < %{guzzlehttp_promises_max_ver})
Requires:(php-composer(psr/log) >= %{psr_log_min_ver} with php-composer(psr/log) < %{psr_log_max_ver})
Requires:(php-composer(%{composer_vendor}/contracts) >= %{symfony_contracts_min_ver} with php-composer(%{composer_vendor}/contracts) < %{symfony_contracts_max_ver})
-Requires:(php-composer(%{composer_vendor}/polyfill-php73) >= %{symfony_polyfill_min_ver} with php-composer(%{composer_vendor}/polyfill-php73) < %{symfony_polyfill_max_ver})
%else
Requires: php-composer(guzzlehttp/promises) < %{guzzlehttp_promises_max_ver}
Requires: php-composer(guzzlehttp/promises) >= %{guzzlehttp_promises_min_ver}
@@ -1363,8 +1359,6 @@ Requires: php-composer(psr/log) < %{psr_log_max_ver}
Requires: php-composer(psr/log) >= %{psr_log_min_ver}
Requires: php-composer(%{composer_vendor}/contracts) < %{symfony_contracts_max_ver}
Requires: php-composer(%{composer_vendor}/contracts) >= %{symfony_contracts_min_ver}
-Requires: php-composer(%{composer_vendor}/polyfill-php73) < %{symfony_polyfill_max_ver}
-Requires: php-composer(%{composer_vendor}/polyfill-php73) >= %{symfony_polyfill_min_ver}
%endif
# phpcompatinfo for version 4.3.6
@@ -1442,7 +1436,6 @@ Requires: php-composer(%{composer_vendor}/http-foundation) = %{version}
%if %{with_range_dependencies}
Requires:(php-composer(psr/log) >= %{psr_log_min_ver} with php-composer(psr/log) < %{psr_log_max_ver})
Requires:(php-composer(%{composer_vendor}/contracts) >= %{symfony_contracts_min_ver} with php-composer(%{composer_vendor}/contracts) < %{symfony_contracts_max_ver})
-Requires:(php-composer(%{composer_vendor}/polyfill-php73) >= %{symfony_polyfill_min_ver} with php-composer(%{composer_vendor}/polyfill-php73) < %{symfony_polyfill_max_ver})
# composer.json: optional
Suggests: php-composer(%{composer_vendor}/browser-kit)
Suggests: php-composer(%{composer_vendor}/config)
@@ -1453,8 +1446,6 @@ Requires: php-composer(psr/log) >= %{psr_log_min_ver}
Requires: php-composer(psr/log) < %{psr_log_max_ver}
Requires: php-composer(%{composer_vendor}/contracts) < %{symfony_contracts_max_ver}
Requires: php-composer(%{composer_vendor}/contracts) >= %{symfony_contracts_min_ver}
-Requires: php-composer(%{composer_vendor}/polyfill-php73) < %{symfony_polyfill_max_ver}
-Requires: php-composer(%{composer_vendor}/polyfill-php73) >= %{symfony_polyfill_min_ver}
%endif
# phpcompatinfo for version 4.0.0-beta1
Requires: php-ctype
@@ -2102,17 +2093,12 @@ URL: http://symfony.com/doc/%{symfony4_doc_ver}/components/var_dumper.html
Requires: %{name}-common = %{version}-%{release}
# composer.json
%if %{with_range_dependencies}
-# composer.json
-Requires:(php-composer(%{composer_vendor}/polyfill-php72) >= %{symfony_polyfill_min_ver} with php-composer(%{composer_vendor}/polyfill-php72) < %{symfony_polyfill_max_ver})
# composer.json: optional
## ext-symfony_debug
Recommends: php-composer(%{composer_vendor}/console)
Suggests: php-mysql
Suggests: php-pecl(amqp)
Suggests: php-pgsql
-%else
-Requires: php-composer(%{composer_vendor}/polyfill-php72) < %{symfony_polyfill_max_ver}
-Requires: php-composer(%{composer_vendor}/polyfill-php72) >= %{symfony_polyfill_min_ver}
%endif
# phpcompatinfo for version 4.0.0-beta1
Requires: php-curl
@@ -2184,14 +2170,11 @@ Requires: %{name}-common = %{version}-%{release}
# composer.json
%if %{with_range_dependencies}
Requires:(php-composer(psr/link) >= %{psr_link_min_ver} with php-composer(psr/link) < %{psr_link_max_ver})
-Requires:(php-composer(%{composer_vendor}/polyfill-php72) >= %{symfony_polyfill_min_ver} with php-composer(%{composer_vendor}/polyfill-php72) < %{symfony_polyfill_max_ver})
# composer.json: optional
Suggests: php-composer(%{composer_vendor}/http-kernel)
%else
Requires: php-composer(psr/link) < %{psr_link_max_ver}
Requires: php-composer(psr/link) >= %{psr_link_min_ver}
-Requires: php-composer(%{composer_vendor}/polyfill-php72) < %{symfony_polyfill_max_ver}
-Requires: php-composer(%{composer_vendor}/polyfill-php72) >= %{symfony_polyfill_min_ver}
%endif
# phpcompatinfo for version 4.0.0-beta1
# <none>