summaryrefslogtreecommitdiffstats
path: root/php-symfony.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-01-06 10:23:21 +0100
committerRemi Collet <fedora@famillecollet.com>2014-01-06 10:23:21 +0100
commitcced5100b3530485d1f1afeee92f3b410e1ba2aa (patch)
treec4faf651c8749f518ee9925671175304493e756a /php-symfony.spec
parent1c343d260f47b11c8819f7f2f75b704b4d235415 (diff)
php-symfony: 2.3.9 (backport)
Diffstat (limited to 'php-symfony.spec')
-rw-r--r--php-symfony.spec27
1 files changed, 20 insertions, 7 deletions
diff --git a/php-symfony.spec b/php-symfony.spec
index 45ce819..f5ce5b7 100644
--- a/php-symfony.spec
+++ b/php-symfony.spec
@@ -1,7 +1,7 @@
%global github_owner symfony
%global github_name symfony
-%global github_version 2.3.8
-%global github_commit b0b421908d569e5024372ded65857707c409e0f7
+%global github_version 2.3.9
+%global github_commit ee1e0f2ef882ccd6a53ff91e5ffc39a22b6a6b74
# https://github.com/symfony/symfony/issues/9797
# Failed test in Component/HttpFoundation/Tests/Session/Storage/Handler/MemcachedSessionHandlerTest.php
@@ -1246,7 +1246,7 @@ ln -s %{name}-common-%{version} %{buildroot}%{_docdir}/%{name}-%{version}
%check
# Create tests' autoloader
mkdir vendor
-( cat <<'AUTOLOADER'
+cat > vendor/autoload.php <<'AUTOLOADER'
<?php
require_once __DIR__.'/../src/Symfony/Component/ClassLoader/UniversalClassLoader.php';
@@ -1268,17 +1268,17 @@ if (file_exists('%{_datadir}/php/password_compat/password.php')) {
return $loader;
AUTOLOADER
-) > vendor/autoload.php
# Create PHPUnit config w/ colors turned off
-cat phpunit.xml.dist \
- | sed 's/colors="true"/colors="false"/' \
- > phpunit.xml
+sed 's/colors="true"/colors="false"/' phpunit.xml.dist > phpunit.xml
# Skip tests that rely on external resources
sed -i \
's/function testNonSeekableStream/function SKIP_testNonSeekableStream/' \
src/Symfony/Component/Finder/Tests/FinderTest.php
+sed -i \
+ 's/function testCopyForOriginUrlsAndExistingLocalFileDefaultsToNotCopy/function SKIP_testCopyForOriginUrlsAndExistingLocalFileDefaultsToNotCopy/' \
+ src/Symfony/Component/Filesystem/Tests/FilesystemTest.php
# Temporarily skip tests that are known to fail
%if 0%{?rhel}
@@ -1289,6 +1289,9 @@ sed -i \
-e 's/function testConstructorHandlesFormAttribute/function SKIP_testConstructorHandlesFormAttribute/' \
-e 's/function testConstructorHandlesFormValues/function SKIP_testConstructorHandlesFormValues/' \
src/Symfony/Component/DomCrawler/Tests/FormTest.php
+sed -i \
+ 's/function testSetContent/function SKIP_testSetContent/' \
+ src/Symfony/Component/HttpFoundation/Tests/JsonResponseTest.php
rm -f src/Symfony/Component/HttpFoundation/Tests/Session/Storage/Handler/NativeFileSessionHandlerTest.php
%endif
@@ -1887,6 +1890,16 @@ done
# ##############################################################################
%changelog
+* Mon Jan 6 2014 Remi Collet <remi@fedoraproject.org> 2.3.9-1
+- backport 2.3.9 for remi repo
+
+* Sun Jan 05 2014 Shawn Iwinski <shawn.iwinski@gmail.com> 2.3.9-1
+- Updated to 2.3.9
+- Conditional %%{?dist}
+- Minor bash cosmetic changes
+- Skip additional test relying on external resources
+- Skip additional el6 test
+
* Tue Dec 17 2013 Remi Collet <remi@fedoraproject.org> 2.3.8-1
- Updated to 2.3.8