summaryrefslogtreecommitdiffstats
path: root/php-symfony.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-03-18 19:07:59 +0100
committerRemi Collet <fedora@famillecollet.com>2015-03-18 19:07:59 +0100
commit5914c2d3be965c828681a7f0354e2709f7eddcee (patch)
tree208799021357e49c6ec568f06f3a730e599b1c19 /php-symfony.spec
parentb93cf0b24c6cd5b8f82b1bccb7f56ff5628d4ec8 (diff)
php-symfony: 2.5.10
Diffstat (limited to 'php-symfony.spec')
-rw-r--r--php-symfony.spec17
1 files changed, 12 insertions, 5 deletions
diff --git a/php-symfony.spec b/php-symfony.spec
index 02d82bb..99b7073 100644
--- a/php-symfony.spec
+++ b/php-symfony.spec
@@ -1,7 +1,7 @@
#
# RPM spec file for php-symfony
#
-# Copyright (c) 2013-2014 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2013-2015 Shawn Iwinski <shawn.iwinski@gmail.com>
# Remi Collet <remi@fedoraproject.org>
#
# License: MIT
@@ -13,8 +13,9 @@
%{!?php_version: %global php_version %(php -r 'echo PHP_VERSION;' 2>/dev/null)}
%global github_owner symfony
%global github_name symfony
-%global github_version 2.5.8
-%global github_commit 00da57005c9c76773670f4d958dd95e9f4ae72f6
+%global github_version 2.5.10
+%global github_commit 6ffe6437a9e734eabd6d092387f065bebfefcd24
+%global github_short %(c=%{github_commit}; echo ${c:0:7})
%global composer_vendor symfony
%global composer_project symfony
@@ -80,7 +81,7 @@ Summary: PHP framework for web projects
Group: Development/Libraries
License: MIT
URL: http://symfony.com
-Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{name}-%{github_version}-%{github_short}.tar.gz
# Run this command to download the PEAR packages
# and retrieve files missing from github archive
@@ -1583,6 +1584,8 @@ sed 's/function testClassNotFound/ function SKIP_testClassNotFound/' \
-i src/Symfony/Component/Debug/Tests/FatalErrorHandler/ClassNotFoundFatalErrorHandlerTest.php
sed 's/function testDumpRelativeDir/function SKIP_testDumpRelativeDir/' \
-i src/Symfony/Component/DependencyInjection/Tests/Dumper/PhpDumperTest.php
+sed 's/function testHandleClassNotFound/function SKIP_testHandleClassNotFound/' \
+ -i src/Symfony/Component/Debug/Tests/FatalErrorHandler/ClassNotFoundFatalErrorHandlerTest.php
%if 0%{?rhel}
sed 's/function testForm/function SKIP_testForm/' \
@@ -2113,7 +2116,8 @@ exit $RET
%exclude %{symfony_dir}/Component/Security/*.md
%exclude %{symfony_dir}/Component/Security/composer.json
%exclude %{symfony_dir}/Component/Security/phpunit.*
-%exclude %{symfony_dir}/Component/Security/Tests
+%exclude %{symfony_dir}/Component/Security/*/phpunit.*
+#exclude %{symfony_dir}/Component/Security/Tests
%exclude %{symfony_dir}/Component/Security/*/Tests
# ------------------------------------------------------------------------------
@@ -2209,6 +2213,9 @@ exit $RET
# ##############################################################################
%changelog
+* Wed Mar 18 2015 Remi Collet <remi@fedoraproject.org> - 2.5.10-1
+- Update to 2.5.10
+
* Mon Dec 15 2014 Remi Collet <remi@fedoraproject.org> - 2.5.8-1
- Update to 2.5.8