summaryrefslogtreecommitdiffstats
path: root/php-symfony.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-29 15:30:51 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-29 15:30:51 +0200
commit1445f773e8ea651618605b5f0090da2c703e574f (patch)
treebb5244152964de07662612159def544c61ad3a82 /php-symfony.spec
parente6367574ed98425abb3331d196b94f3472ad6198 (diff)
php-symfony: cleanup autoloader
Diffstat (limited to 'php-symfony.spec')
-rw-r--r--php-symfony.spec17
1 files changed, 10 insertions, 7 deletions
diff --git a/php-symfony.spec b/php-symfony.spec
index 4e0b9d2..069de1d 100644
--- a/php-symfony.spec
+++ b/php-symfony.spec
@@ -95,7 +95,7 @@
Name: php-%{composer_project}
Version: %{github_version}
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: PHP framework for web projects
Group: Development/Libraries
@@ -1676,7 +1676,13 @@ if (!isset($fedoraClassLoader) || !($fedoraClassLoader instanceof \Symfony\Compo
$fedoraClassLoader->addPrefix('Symfony\\Component\\', dirname(dirname(__DIR__)));
// Optional dependency
-@include_once '%{phpdir}/random_compat/autoload.php';
+foreach (array(
+ '%{phpdir}/random_compat/autoload.php',
+) as $dependencyAutoloader) {
+ if (file_exists($dependencyAutoloader)) {
+ require_once $dependencyAutoloader;
+ }
+}
return $fedoraClassLoader;
AUTOLOAD
@@ -1720,10 +1726,6 @@ foreach (array(
}
}
-if (!interface_exists('SessionHandlerInterface', false) && file_exists(__DIR__ . '/Component/HttpFoundation/Resources/stubs/SessionHandlerInterface.php')) {
- require_once __DIR__ . '/Component/HttpFoundation/Resources/stubs/SessionHandlerInterface.php';
-}
-
$fedoraClassLoader->setUseIncludePath(true);
return $fedoraClassLoader;
@@ -2530,8 +2532,9 @@ exit $RET
# ##############################################################################
%changelog
-* Fri Apr 29 2016 Remi Collet <remi@fedoraproject.org> - 2.7.12-1
+* Fri Apr 29 2016 Remi Collet <remi@fedoraproject.org> - 2.7.12-2
- Update to 2.7.12
+- cleanup autoloader
* Sat Mar 26 2016 Remi Collet <remi@fedoraproject.org> - 2.7.11-2
- Update to 2.7.11