summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-04-14 07:39:13 +0200
committerRemi Collet <remi@remirepo.net>2017-04-14 07:39:13 +0200
commitaadef742f63440e9c6405f8063b3121129e87e17 (patch)
tree7a617dcba32fd58a7667d877813667168a3ccb47
parentf8964c871fc958162dbc6e6071b3c699205b9d06 (diff)
sync with Fedora + cleanup
-rw-r--r--php-symfony.spec97
1 files changed, 40 insertions, 57 deletions
diff --git a/php-symfony.spec b/php-symfony.spec
index ac07709..100b458 100644
--- a/php-symfony.spec
+++ b/php-symfony.spec
@@ -72,8 +72,8 @@
# "swiftmailer/swiftmailer": ">=4.2.0,<6.0-dev"
# src/Symfony/Bridge/Swiftmailer/composer.json
# NOTE: Min version not 4.2.0 because autoloader required
-# NOTE: Max version ignored on purpose
%global swiftmailer_min_ver 5.4.1
+%global swiftmailer_max_ver 6.0
# "symfony/polyfill-php54": "~1.0"
# "symfony/polyfill-php55": "~1.0"
# "symfony/polyfill-php56": "~1.0"
@@ -106,7 +106,7 @@
Name: php-%{composer_project}
Version: %{github_version}
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: PHP framework for web projects
Group: Development/Libraries
@@ -114,7 +114,6 @@ License: MIT
URL: http://symfony.com
Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{name}-%{github_version}-%{github_short}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -122,24 +121,43 @@ BuildArch: noarch
# Force version to 4.8 for autoloader
BuildRequires: php-composer(phpunit/phpunit) >= 4.8
BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: php-composer(doctrine/annotations) < %{doctrine_annotations_max_ver}
BuildRequires: php-composer(doctrine/annotations) >= %{doctrine_annotations_min_ver}
+BuildRequires: php-composer(doctrine/cache) < %{doctrine_cache_max_ver}
BuildRequires: php-composer(doctrine/cache) >= %{doctrine_cache_min_ver}
+BuildRequires: php-composer(doctrine/common) < %{doctrine_common_max_ver}
BuildRequires: php-composer(doctrine/common) >= %{doctrine_common_min_ver}
+BuildRequires: php-composer(doctrine/data-fixtures) < %{doctrine_datafixtures_max_ver}
BuildRequires: php-composer(doctrine/data-fixtures) >= %{doctrine_datafixtures_min_ver}
+BuildRequires: php-composer(doctrine/dbal) < %{doctrine_dbal_max_ver}
BuildRequires: php-composer(doctrine/dbal) >= %{doctrine_dbal_min_ver}
+BuildRequires: php-composer(doctrine/doctrine-bundle) < %{doctrine_bundle_max_ver}
BuildRequires: php-composer(doctrine/doctrine-bundle) >= %{doctrine_bundle_min_ver}
+BuildRequires: php-composer(doctrine/orm) < %{doctrine_orm_max_ver}
BuildRequires: php-composer(doctrine/orm) >= %{doctrine_orm_min_ver}
+BuildRequires: php-composer(egulias/email-validator) < %{email_validator_max_ver}
BuildRequires: php-composer(egulias/email-validator) >= %{email_validator_min_ver}
+BuildRequires: php-composer(monolog/monolog) < %{monolog_max_ver}
BuildRequires: php-composer(monolog/monolog) >= %{monolog_min_ver}
+BuildRequires: php-composer(ocramius/proxy-manager) < %{proxy_manager_max_ver}
BuildRequires: php-composer(ocramius/proxy-manager) >= %{proxy_manager_min_ver}
+BuildRequires: php-composer(phpdocumentor/reflection) < %{phpdocumentor_reflection_max_ver}
BuildRequires: php-composer(phpdocumentor/reflection) >= %{phpdocumentor_reflection_min_ver}
+BuildRequires: php-composer(psr/log) < %{psr_log_max_ver}
BuildRequires: php-composer(psr/log) >= %{psr_log_min_ver}
+BuildRequires: php-composer(swiftmailer/swiftmailer) < %{swiftmailer_max_ver}
BuildRequires: php-composer(swiftmailer/swiftmailer) >= %{swiftmailer_min_ver}
+BuildRequires: php-composer(symfony/polyfill-php54) < %{symfony_polyfill_max_ver}
BuildRequires: php-composer(symfony/polyfill-php54) >= %{symfony_polyfill_min_ver}
+BuildRequires: php-composer(symfony/polyfill-php55) < %{symfony_polyfill_max_ver}
BuildRequires: php-composer(symfony/polyfill-php55) >= %{symfony_polyfill_min_ver}
+BuildRequires: php-composer(symfony/polyfill-php56) < %{symfony_polyfill_max_ver}
BuildRequires: php-composer(symfony/polyfill-php56) >= %{symfony_polyfill_min_ver}
+BuildRequires: php-composer(symfony/polyfill-php70) < %{symfony_polyfill_max_ver}
BuildRequires: php-composer(symfony/polyfill-php70) >= %{symfony_polyfill_min_ver}
+BuildRequires: php-composer(symfony/polyfill-util) < %{symfony_polyfill_max_ver}
BuildRequires: php-composer(symfony/polyfill-util) >= %{symfony_polyfill_min_ver}
+BuildRequires: php-composer(symfony/security-acl) < %{symfony_security_acl_max_ver}
BuildRequires: php-composer(symfony/security-acl) >= %{symfony_security_acl_min_ver}
# Notice Symfony\Bridge\Twig\Tests\Node\TransNodeTest::testCompileStrict fails with v2
# Legacy deprecation notices (13)
@@ -164,16 +182,13 @@ BuildRequires: php-pcntl
BuildRequires: php-pcre
BuildRequires: php-pdo
BuildRequires: php-posix
-# php-cli instead of php-readline for EL-5
-BuildRequires: php-cli
+BuildRequires: php-readline
BuildRequires: php-reflection
BuildRequires: php-session
BuildRequires: php-simplexml
BuildRequires: php-sockets
BuildRequires: php-spl
-%if 0%{?rhel} != 5
BuildRequires: php-sqlite3
-%endif
BuildRequires: php-tokenizer
BuildRequires: php-xml
%endif
@@ -385,6 +400,7 @@ Summary: Symfony Swiftmailer Bridge
Group: Development/Libraries
# composer.json
+Requires: php-composer(swiftmailer/swiftmailer) < %{swiftmailer_max_ver}
Requires: php-composer(swiftmailer/swiftmailer) >= %{swiftmailer_min_ver}
# composer.json: optional
Requires: php-composer(%{composer_vendor}/http-kernel) = %{version}
@@ -783,8 +799,7 @@ Requires: php-json
Requires: php-mbstring
Requires: php-pcre
Requires: php-posix
-# php-cli instead of php-readline for EL-5
-Requires: php-cli
+Requires: php-readline
Requires: php-reflection
Requires: php-spl
@@ -1169,9 +1184,7 @@ Requires: php-pdo
Requires: php-reflection
Requires: php-session
Requires: php-spl
-%if 0%{?rhel} != 5
Requires: php-sqlite3
-%endif
Requires: php-tokenizer
# Composer
@@ -1835,7 +1848,6 @@ foreach (array(
'%{phpdir}/Doctrine/ORM/autoload.php',
'%{phpdir}/Egulias/EmailValidator/autoload.php',
'%{phpdir}/Monolog/autoload.php',
- '%{phpdir}/phpDocumentor/Reflection/autoload.php',
'%{phpdir}/ProxyManager/autoload.php',
'%{phpdir}/Psr/Log/autoload.php',
'%{phpdir}/Swift/swift_required.php',
@@ -1846,11 +1858,17 @@ foreach (array(
require_once $dependencyAutoloader;
}
}
+if (file_exists($dep='%{phpdir}/phpDocumentor/Reflection1/autoload.php')) {
+ require_once $dep;
+} else if (file_exists($dep='%{phpdir}/phpDocumentor/Reflection/autoload.php')) {
+ require_once $dep;
+}
if (file_exists($dep='%{phpdir}/Twig2/autoload.php')) {
require_once $dep;
} else if (file_exists($dep='%{phpdir}/Twig/autoload.php')) {
require_once $dep;
}
+
return $fedoraClassLoader;
AUTOLOAD
@@ -1926,6 +1944,10 @@ sed -e 's/testCopyForOriginUrlsAndExistingLocalFileDefaultsToCopy/SKIP_testCopyF
rm src/Symfony/Component/Form/Tests/Extension/Core/Type/DateTypeTest.php
rm src/Symfony/Component/Form/Tests/Extension/Core/Type/BirthdayTypeTest.php
%endif
+%if 0%{?fedora} >= 25
+: see https://github.com/symfony/symfony/issues/22266
+rm src/Symfony/Component/VarDumper/Tests/CliDumperTest.php
+%endif
%endif
@@ -1983,7 +2005,6 @@ exit $RET
%{!?_licensedir:%global license %%doc}
%files
-%defattr(-,root,root,-)
%if 0%{?fedora} >= 20
%doc %{_docdir}/%{name}
%else
@@ -1994,7 +2015,6 @@ exit $RET
# ##############################################################################
%files common
-%defattr(-,root,root,-)
%doc *.md composer.json
%license LICENSE
@@ -2009,7 +2029,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files doctrine-bridge
-%defattr(-,root,root,-)
%license src/Symfony/Bridge/Doctrine/LICENSE
%doc src/Symfony/Bridge/Doctrine/*.md
@@ -2025,7 +2044,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files monolog-bridge
-%defattr(-,root,root,-)
%license src/Symfony/Bridge/Monolog/LICENSE
%doc src/Symfony/Bridge/Monolog/*.md
@@ -2041,7 +2059,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files phpunit-bridge
-%defattr(-,root,root,-)
%license src/Symfony/Bridge/PhpUnit/LICENSE
%doc src/Symfony/Bridge/PhpUnit/*.md
@@ -2057,7 +2074,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files proxy-manager-bridge
-%defattr(-,root,root,-)
%license src/Symfony/Bridge/ProxyManager/LICENSE
%doc src/Symfony/Bridge/ProxyManager/*.md
@@ -2073,7 +2089,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files swiftmailer-bridge
-%defattr(-,root,root,-)
%license src/Symfony/Bridge/Swiftmailer/LICENSE
%doc src/Symfony/Bridge/Swiftmailer/*.md
@@ -2089,7 +2104,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files twig-bridge
-%defattr(-,root,root,-)
%license src/Symfony/Bridge/Twig/LICENSE
%doc src/Symfony/Bridge/Twig/*.md
@@ -2105,7 +2119,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files debug-bundle
-%defattr(-,root,root,-)
#%%doc src/Symfony/Bundle/DebugBundle/*.md
%doc src/Symfony/Bundle/DebugBundle/composer.json
@@ -2121,7 +2134,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files framework-bundle
-%defattr(-,root,root,-)
%doc src/Symfony/Bundle/FrameworkBundle/*.md
%doc src/Symfony/Bundle/FrameworkBundle/composer.json
@@ -2137,7 +2149,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files security-bundle
-%defattr(-,root,root,-)
%doc src/Symfony/Bundle/SecurityBundle/*.md
%doc src/Symfony/Bundle/SecurityBundle/composer.json
@@ -2153,7 +2164,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files twig-bundle
-%defattr(-,root,root,-)
%doc src/Symfony/Bundle/TwigBundle/*.md
%doc src/Symfony/Bundle/TwigBundle/composer.json
@@ -2169,7 +2179,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files web-profiler-bundle
-%defattr(-,root,root,-)
%doc src/Symfony/Bundle/WebProfilerBundle/*.md
%doc src/Symfony/Bundle/WebProfilerBundle/composer.json
@@ -2187,7 +2196,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files asset
-%defattr(-,root,root,-)
%license src/Symfony/Component/Asset/LICENSE
%doc src/Symfony/Component/Asset/*.md
@@ -2203,7 +2211,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files browser-kit
-%defattr(-,root,root,-)
%license src/Symfony/Component/BrowserKit/LICENSE
%doc src/Symfony/Component/BrowserKit/*.md
@@ -2219,7 +2226,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files class-loader
-%defattr(-,root,root,-)
%license src/Symfony/Component/ClassLoader/LICENSE
%doc src/Symfony/Component/ClassLoader/*.md
@@ -2235,7 +2241,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files config
-%defattr(-,root,root,-)
%license src/Symfony/Component/Config/LICENSE
%doc src/Symfony/Component/Config/*.md
@@ -2251,7 +2256,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files console
-%defattr(-,root,root,-)
%license src/Symfony/Component/Console/LICENSE
%doc src/Symfony/Component/Console/*.md
@@ -2267,7 +2271,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files css-selector
-%defattr(-,root,root,-)
%license src/Symfony/Component/CssSelector/LICENSE
%doc src/Symfony/Component/CssSelector/*.md
@@ -2283,7 +2286,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files debug
-%defattr(-,root,root,-)
%license src/Symfony/Component/Debug/LICENSE
%doc src/Symfony/Component/Debug/*.md
@@ -2300,7 +2302,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files dependency-injection
-%defattr(-,root,root,-)
%license src/Symfony/Component/DependencyInjection/LICENSE
%doc src/Symfony/Component/DependencyInjection/*.md
@@ -2316,7 +2317,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files dom-crawler
-%defattr(-,root,root,-)
%license src/Symfony/Component/DomCrawler/LICENSE
%doc src/Symfony/Component/DomCrawler/*.md
@@ -2332,7 +2332,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files event-dispatcher
-%defattr(-,root,root,-)
%license src/Symfony/Component/EventDispatcher/LICENSE
%doc src/Symfony/Component/EventDispatcher/*.md
@@ -2348,7 +2347,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files expression-language
-%defattr(-,root,root,-)
%license src/Symfony/Component/ExpressionLanguage/LICENSE
%doc src/Symfony/Component/ExpressionLanguage/*.md
@@ -2364,7 +2362,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files filesystem
-%defattr(-,root,root,-)
%license src/Symfony/Component/Filesystem/LICENSE
%doc src/Symfony/Component/Filesystem/*.md
@@ -2380,7 +2377,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files finder
-%defattr(-,root,root,-)
%license src/Symfony/Component/Finder/LICENSE
%doc src/Symfony/Component/Finder/*.md
@@ -2396,7 +2392,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files form
-%defattr(-,root,root,-)
%license src/Symfony/Component/Form/LICENSE
%doc src/Symfony/Component/Form/*.md
@@ -2412,7 +2407,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files http-foundation
-%defattr(-,root,root,-)
%license src/Symfony/Component/HttpFoundation/LICENSE
%doc src/Symfony/Component/HttpFoundation/*.md
@@ -2428,7 +2422,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files http-kernel
-%defattr(-,root,root,-)
%license src/Symfony/Component/HttpKernel/LICENSE
%doc src/Symfony/Component/HttpKernel/*.md
@@ -2444,7 +2437,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files intl
-%defattr(-,root,root,-)
%license src/Symfony/Component/Intl/LICENSE
%doc src/Symfony/Component/Intl/*.md
@@ -2460,7 +2452,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files ldap
-%defattr(-,root,root,-)
%license src/Symfony/Component/Ldap/LICENSE
%doc src/Symfony/Component/Ldap/*.md
@@ -2476,7 +2467,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files locale
-%defattr(-,root,root,-)
%license src/Symfony/Component/Locale/LICENSE
%doc src/Symfony/Component/Locale/*.md
@@ -2492,7 +2482,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files options-resolver
-%defattr(-,root,root,-)
%license src/Symfony/Component/OptionsResolver/LICENSE
%doc src/Symfony/Component/OptionsResolver/*.md
@@ -2508,7 +2497,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files process
-%defattr(-,root,root,-)
%license src/Symfony/Component/Process/LICENSE
%doc src/Symfony/Component/Process/*.md
@@ -2524,7 +2512,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files property-access
-%defattr(-,root,root,-)
%license src/Symfony/Component/PropertyAccess/LICENSE
%doc src/Symfony/Component/PropertyAccess/*.md
@@ -2540,7 +2527,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files property-info
-%defattr(-,root,root,-)
%license src/Symfony/Component/PropertyInfo/LICENSE
%doc src/Symfony/Component/PropertyInfo/*.md
@@ -2556,7 +2542,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files routing
-%defattr(-,root,root,-)
%license src/Symfony/Component/Routing/LICENSE
%doc src/Symfony/Component/Routing/*.md
@@ -2572,7 +2557,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files security
-%defattr(-,root,root,-)
%license src/Symfony/Component/Security/LICENSE
%doc src/Symfony/Component/Security/*.md
@@ -2593,7 +2577,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files serializer
-%defattr(-,root,root,-)
%license src/Symfony/Component/Serializer/LICENSE
%doc src/Symfony/Component/Serializer/*.md
@@ -2609,7 +2592,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files stopwatch
-%defattr(-,root,root,-)
%license src/Symfony/Component/Stopwatch/LICENSE
%doc src/Symfony/Component/Stopwatch/*.md
@@ -2625,7 +2607,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files templating
-%defattr(-,root,root,-)
%license src/Symfony/Component/Templating/LICENSE
%doc src/Symfony/Component/Templating/*.md
@@ -2641,7 +2622,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files translation
-%defattr(-,root,root,-)
%license src/Symfony/Component/Translation/LICENSE
%doc src/Symfony/Component/Translation/*.md
@@ -2657,7 +2637,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files validator
-%defattr(-,root,root,-)
%license src/Symfony/Component/Validator/LICENSE
%doc src/Symfony/Component/Validator/*.md
@@ -2673,7 +2652,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files var-dumper
-%defattr(-,root,root,-)
%license src/Symfony/Component/VarDumper/LICENSE
%doc src/Symfony/Component/VarDumper/*.md
@@ -2689,7 +2667,6 @@ exit $RET
# ------------------------------------------------------------------------------
%files yaml
-%defattr(-,root,root,-)
%license src/Symfony/Component/Yaml/LICENSE
%doc src/Symfony/Component/Yaml/*.md
@@ -2705,6 +2682,12 @@ exit $RET
# ##############################################################################
%changelog
+* Wed Apr 12 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 2.8.19-2
+- Add max versions to BuildRequires
+- Add max swiftmailer/swiftmailer dependency version
+- Prepare for php-phpdocumentor-reflection => php-phpdocumentor-reflection1
+ dependency rename
+
* Wed Apr 5 2017 Remi Collet <remi@remirepo.net> - 2.8.19-1
- Update to 2.8.19