summaryrefslogtreecommitdiffstats
path: root/php-symfony-polyfill.spec
diff options
context:
space:
mode:
authorShawn Iwinski <shawn@iwin.ski>2017-08-30 16:19:11 +0000
committerRemi Collet <remi@remirepo.net>2017-09-04 12:46:55 +0200
commit561ffc50e065119882fb10465c582d5504f7031f (patch)
treee20c75de312389e2e659ca00875a513fc581ca9d /php-symfony-polyfill.spec
parent7639e5e7735da6f325ec77976a44e976bfa92a2a (diff)
Updated to 1.5.0 (RHBZ #1482156)
- Added version constraints to ircmaxell/password-compat - Added max version constraint to paragonie/random_compat BuildeRequires - Removed php-mbstring dependency
Diffstat (limited to 'php-symfony-polyfill.spec')
-rw-r--r--php-symfony-polyfill.spec28
1 files changed, 19 insertions, 9 deletions
diff --git a/php-symfony-polyfill.spec b/php-symfony-polyfill.spec
index 9a034c8..6fe9575 100644
--- a/php-symfony-polyfill.spec
+++ b/php-symfony-polyfill.spec
@@ -12,14 +12,17 @@
%global github_owner symfony
%global github_name polyfill
-%global github_version 1.4.0
-%global github_commit a80c6de45ebd2a041415ba17879ff7309ead51f6
+%global github_version 1.5.0
+%global github_commit 157dfe598da2181908ff2345cad1807b2c23f5f9
%global composer_vendor symfony
%global composer_project polyfill
# "php": ">=5.3.3"
%global php_min_ver 5.3.3
+# "ircmaxell/password-compat": "~1.0"
+%global ircmaxell_password_compat_min_ver 1.0
+%global ircmaxell_password_compat_max_ver 2.0
# "paragonie/random_compat": "~1.0|~2.0"
%global paragonie_random_compat_min_ver 1.0
%global paragonie_random_compat_max_ver 3.0
@@ -47,13 +50,14 @@ BuildRequires: php-fedora-autoloader-devel
BuildRequires: php-composer(phpunit/phpunit)
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
-BuildRequires: php-composer(ircmaxell/password-compat)
+BuildRequires: php-composer(ircmaxell/password-compat) < %{ircmaxell_password_compat_max_ver}
+BuildRequires: php-composer(ircmaxell/password-compat) >= %{ircmaxell_password_compat_min_ver}
+BuildRequires: php-composer(paragonie/random_compat) < %{paragonie_random_compat_max_ver}
BuildRequires: php-composer(paragonie/random_compat) >= %{paragonie_random_compat_min_ver}
-## phpcompatinfo (computed from version 1.3.0)
+## phpcompatinfo (computed from version 1.5.0)
BuildRequires: php-hash
BuildRequires: php-json
BuildRequires: php-ldap
-BuildRequires: php-mbstring
BuildRequires: php-pcre
BuildRequires: php-reflection
BuildRequires: php-spl
@@ -61,13 +65,13 @@ BuildRequires: php-spl
# composer.json
Requires: php(language) >= %{php_min_ver}
-Requires: php-composer(ircmaxell/password-compat)
-Requires: php-composer(paragonie/random_compat) >= %{paragonie_random_compat_min_ver}
+Requires: php-composer(ircmaxell/password-compat) < %{ircmaxell_password_compat_max_ver}
+Requires: php-composer(ircmaxell/password-compat) >= %{ircmaxell_password_compat_min_ver}
Requires: php-composer(paragonie/random_compat) < %{paragonie_random_compat_max_ver}
-# phpcompatinfo (computed from version 1.3.0)
+Requires: php-composer(paragonie/random_compat) >= %{paragonie_random_compat_min_ver}
+# phpcompatinfo (computed from version 1.5.0)
Requires: php-hash
Requires: php-json
-Requires: php-mbstring
Requires: php-pcre
Requires: php-reflection
Requires: php-spl
@@ -164,6 +168,12 @@ exit $RETURN_CODE
%changelog
+* Wed Aug 30 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.5.0-1
+- Updated to 1.5.0 (RHBZ #1482156)
+- Added version constraints to ircmaxell/password-compat
+- Added max version constraint to paragonie/random_compat BuildeRequires
+- Removed php-mbstring dependency
+
* Sun Jul 09 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.4.0-1
- Updated to 1.4.0 (RHBZ #1460473)
- Provide php-composer(symfony/polyfill-php72)