summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-13 07:18:51 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-13 07:18:51 +0200
commit6224f8e8f69c68324035d89c005a3626f4fa59c2 (patch)
treec72862bcb16de4d0e8c92851dbddab66013821b9
parent31b08c64c610dfea6fff5d1427a51c695ea50014 (diff)
php-symfony-polyfill: 1.1.1 (backported from Fedora)
-rw-r--r--composer.json65
-rw-r--r--php-symfony-polyfill.spec15
2 files changed, 73 insertions, 7 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..fc21007
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,65 @@
+{
+ "name": "symfony/polyfill",
+ "type": "library",
+ "description": "Symfony polyfills backporting features to lower PHP versions",
+ "keywords": ["polyfill", "shim", "compat", "compatibility"],
+ "homepage": "https://symfony.com",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Nicolas Grekas",
+ "email": "p@tchwork.com"
+ },
+ {
+ "name": "Symfony Community",
+ "homepage": "https://symfony.com/contributors"
+ }
+ ],
+ "require": {
+ "php": ">=5.3.3",
+ "ircmaxell/password-compat": "~1.0",
+ "paragonie/random_compat": "~1.0",
+ "symfony/intl": "~2.3|~3.0"
+ },
+ "replace": {
+ "symfony/polyfill-apcu": "self.version",
+ "symfony/polyfill-php54": "self.version",
+ "symfony/polyfill-php55": "self.version",
+ "symfony/polyfill-php56": "self.version",
+ "symfony/polyfill-php70": "self.version",
+ "symfony/polyfill-iconv": "self.version",
+ "symfony/polyfill-intl-grapheme": "self.version",
+ "symfony/polyfill-intl-icu": "self.version",
+ "symfony/polyfill-intl-normalizer": "self.version",
+ "symfony/polyfill-mbstring": "self.version",
+ "symfony/polyfill-util": "self.version",
+ "symfony/polyfill-xml": "self.version"
+ },
+ "autoload": {
+ "psr-4": { "Symfony\\Polyfill\\": "src/" },
+ "files": [
+ "src/Apcu/bootstrap.php",
+ "src/Php54/bootstrap.php",
+ "src/Php55/bootstrap.php",
+ "src/Php56/bootstrap.php",
+ "src/Php70/bootstrap.php",
+ "src/Iconv/bootstrap.php",
+ "src/Intl/Grapheme/bootstrap.php",
+ "src/Intl/Icu/bootstrap.php",
+ "src/Intl/Normalizer/bootstrap.php",
+ "src/Mbstring/bootstrap.php",
+ "src/Xml/bootstrap.php"
+ ],
+ "classmap": [
+ "src/Intl/Normalizer/Resources/stubs",
+ "src/Php70/Resources/stubs",
+ "src/Php54/Resources/stubs"
+ ]
+ },
+ "minimum-stability": "dev",
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.1-dev"
+ }
+ }
+}
diff --git a/php-symfony-polyfill.spec b/php-symfony-polyfill.spec
index 4be8324..fcdf45a 100644
--- a/php-symfony-polyfill.spec
+++ b/php-symfony-polyfill.spec
@@ -12,8 +12,8 @@
%global github_owner symfony
%global github_name polyfill
-%global github_version 1.0.1
-%global github_commit dd9db1dc4013821a63f7afbd8340dd57939fe674
+%global github_version 1.1.1
+%global github_commit 3dc21aeff3e1f8cb708421ed02cf1a8901d7b535
%global composer_vendor symfony
%global composer_project polyfill
@@ -47,7 +47,7 @@ BuildRequires: php-composer(phpunit/phpunit)
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-composer(ircmaxell/password-compat)
BuildRequires: php-composer(paragonie/random_compat)
-## phpcompatinfo (computed from version 1.0.1)
+## phpcompatinfo (computed from version 1.1.1)
BuildRequires: php-hash
BuildRequires: php-json
BuildRequires: php-ldap
@@ -61,7 +61,7 @@ BuildRequires: php-spl
Requires: php(language) >= %{php_min_ver}
Requires: php-composer(ircmaxell/password-compat)
Requires: php-composer(paragonie/random_compat)
-# phpcompatinfo (computed from version 1.0.1)
+# phpcompatinfo (computed from version 1.1.1)
Requires: php-hash
Requires: php-json
Requires: php-mbstring
@@ -96,9 +96,7 @@ mv src/Php70/{*.md,composer.json} docs/Php70/
mv src/Util/{*.md,composer.json} docs/Util/
: Remove unneeded polyfills
-rm -rf {src,tests}/{Iconv,Intl,Mbstring,Xml}
-
-
+rm -rf {src,tests}/{Apcu,Iconv,Intl,Mbstring,Xml}
%build
@@ -170,6 +168,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Apr 12 2016 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.1.1-1
+- Updated to 1.1.1 (RHBZ #1301791)
+
* Tue Dec 29 2015 Shawn Iwinski <shawn@iwin.ski> - 1.0.1-1
- update to 1.0.1