summaryrefslogtreecommitdiffstats
path: root/php-symfony-contracts2.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-11-23 08:38:42 +0100
committerRemi Collet <remi@php.net>2021-11-23 08:38:42 +0100
commit4c1f463daa2295ea497dee303ba26ebca12b8eda (patch)
tree3d7dd78d20011ee42713fe5b3e779cb04fbec76c /php-symfony-contracts2.spec
parent6a70328f43ca99cac7bd654d260b66402b6914f2 (diff)
update to 2.5.0
allow psr/cache v2 and v3
Diffstat (limited to 'php-symfony-contracts2.spec')
-rw-r--r--php-symfony-contracts2.spec21
1 files changed, 15 insertions, 6 deletions
diff --git a/php-symfony-contracts2.spec b/php-symfony-contracts2.spec
index 9470ded..5719b74 100644
--- a/php-symfony-contracts2.spec
+++ b/php-symfony-contracts2.spec
@@ -9,7 +9,7 @@
%bcond_without tests
-%global gh_commit 8434102b404d119dcaf98c8fe19a2655573ac17a
+%global gh_commit 1f4c95d47bddf0c1579779d4b85602c923ed2f1c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner symfony
%global gh_project contracts
@@ -25,7 +25,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 2.4.0
+Version: 2.5.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A set of abstractions extracted out of the Symfony, version %{major}
@@ -47,7 +47,7 @@ BuildRequires: php-zlib
# "symfony/polyfill-intl-idn": "^1.10"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >=8
-BuildRequires: (php-composer(psr/cache) >= 1.0 with php-composer(psr/cache) < 2)
+BuildRequires: (php-composer(psr/cache) >= 1.0 with php-composer(psr/cache) < 4)
BuildRequires: (php-composer(psr/container) >= 1.1 with php-composer(psr/container) < 2)
BuildRequires: (php-composer(psr/event-dispatcher) >= 1.0 with php-composer(psr/event-dispatcher) < 2)
# remirepo:5
@@ -80,7 +80,7 @@ Requires: php(language) >= 7.2.5
# "symfony/translation-implementation": ""
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >=8
-Requires: (php-composer(psr/cache) >= 1.0 with php-composer(psr/cache) < 2)
+Requires: (php-composer(psr/cache) >= 1.0 with php-composer(psr/cache) < 4)
Requires: (php-composer(psr/container) >= 1.1 with php-composer(psr/container) < 2)
Requires: (php-composer(psr/event-dispatcher) >= 1.0 with php-composer(psr/event-dispatcher) < 2)
# remirepo:5
@@ -138,7 +138,11 @@ require_once '%{php_home}/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('%{ns_vendor}\\%{ns_project}\\', __DIR__);
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/Psr/Cache/autoload.php',
+ [
+ '%{php_home}/Psr/Cache3/autoload.php',
+ '%{php_home}/Psr/Cache2/autoload.php',
+ '%{php_home}/Psr/Cache/autoload.php',
+ ],
'%{php_home}/Psr/Container/autoload.php',
'%{php_home}/Psr/EventDispatcher/autoload.php',
__DIR__ . '/Deprecation/function.php',
@@ -161,10 +165,11 @@ mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
<?php
require_once '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php';
+\Fedora\Autoloader\Autoload::addPsr4('%{ns_vendor}\\%{ns_project}\\Tests\\Fixtures\\', dirname(__DIR__)."/Tests/Fixtures/");
EOF
ret=0
-for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -189,6 +194,10 @@ exit $ret
%changelog
+* Tue Nov 23 2021 Remi Collet <remi@remirepo.net> - 2.5.0-1
+- update to 2.5.0
+- allow psr/cache v2 and v3
+
* Mon Apr 19 2021 Remi Collet <remi@remirepo.net> - 2.4.0-1
- update to 2.4.0
- raise dependency on psr/container 1.1