summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json8
-rw-r--r--php-symfony-contracts.spec24
-rw-r--r--src/Cache/composer.json4
-rw-r--r--src/Service/composer.json4
4 files changed, 22 insertions, 18 deletions
diff --git a/composer.json b/composer.json
index f78ba69..b9277e1 100644
--- a/composer.json
+++ b/composer.json
@@ -16,11 +16,11 @@
}
],
"require": {
- "php": "^7.1.3"
+ "php": "^7.1.3",
+ "psr/cache": "^1.0",
+ "psr/container": "^1.0"
},
"require-dev": {
- "psr/cache": "^1.0",
- "psr/container": "^1.0",
"symfony/polyfill-intl-idn": "^1.10"
},
"replace": {
@@ -31,8 +31,6 @@
"symfony/translation-contracts": "self.version"
},
"suggest": {
- "psr/cache": "When using the Cache contracts",
- "psr/container": "When using the Service contracts",
"psr/event-dispatcher": "When using the EventDispatcher contracts",
"symfony/cache-implementation": "",
"symfony/event-dispatcher-implementation": "",
diff --git a/php-symfony-contracts.spec b/php-symfony-contracts.spec
index ec8cbd1..f89214c 100644
--- a/php-symfony-contracts.spec
+++ b/php-symfony-contracts.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 9cb52490dd60e0f50dbcdbdb3a6dbcb31f3a363e
+%global gh_commit f51bca9de06b7a25b19a4155da7bebad099a5def
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner symfony
%global gh_project contracts
@@ -21,7 +21,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{pk_vendor}-%{pk_project}
-Version: 1.1.7
+Version: 1.1.8
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A set of abstractions extracted out of the Symfony
@@ -39,8 +39,6 @@ BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-intl
# From composer.json, "require-dev": {
-# "psr/cache": "^1.0",
-# "psr/container": "^1.0",
# "symfony/polyfill-intl-idn": "^1.10"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >=8
@@ -59,10 +57,10 @@ BuildRequires: php-composer(fedora/autoloader)
# From composer.json, "require": {
# "php": "^7.1.3"
+# "psr/cache": "^1.0",
+# "psr/container": "^1.0"
Requires: php(language) >= 7.1.3
# From composer.json, "suggest": {
-# "psr/cache": "When using the Cache contracts",
-# "psr/container": "When using the Service contracts",
# "psr/event-dispatcher": "When using the EventDispatcher contracts",
# "symfony/cache-implementation": "",
# "symfony/event-dispatcher-implementation": "",
@@ -71,10 +69,14 @@ Requires: php(language) >= 7.1.3
# "symfony/translation-implementation": ""
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >=8
-Recommends: (php-composer(psr/cache) >= 1.0 with php-composer(psr/cache) < 2)
-Recommends: (php-composer(psr/container) >= 1.0 with php-composer(psr/container) < 2)
+Requires: (php-composer(psr/cache) >= 1.0 with php-composer(psr/cache) < 2)
+Requires: (php-composer(psr/container) >= 1.0 with php-composer(psr/container) < 2)
Recommends: (php-composer(psr/event-dispatcher) >= 1.0 with php-composer(psr/event-dispatcher) < 2)
-# remirepo:1
+# remirepo:4
+%else
+Requires: php-psr-cache
+Requires: php-psr-container
+Requires: php-psr-event-dispatcher
%endif
# From phpcompatinfo report for version 1.1.0
Requires: php-reflection
@@ -169,6 +171,10 @@ exit $ret
%changelog
+* Thu Nov 21 2019 Remi Collet <remi@remirepo.net> - 1.1.8-1
+- update to 1.1.8
+- psr/cache and psr/container are mandatory
+
* Tue Nov 5 2019 Remi Collet <remi@remirepo.net> - 1.1.7-1
- update to 1.1.7
- add missing EventDispatcher and HttpClient directories
diff --git a/src/Cache/composer.json b/src/Cache/composer.json
index d5d7e99..4e0bd1a 100644
--- a/src/Cache/composer.json
+++ b/src/Cache/composer.json
@@ -16,10 +16,10 @@
}
],
"require": {
- "php": "^7.1.3"
+ "php": "^7.1.3",
+ "psr/cache": "^1.0"
},
"suggest": {
- "psr/cache": "",
"symfony/cache-implementation": ""
},
"autoload": {
diff --git a/src/Service/composer.json b/src/Service/composer.json
index 5434117..f4209cc 100644
--- a/src/Service/composer.json
+++ b/src/Service/composer.json
@@ -16,10 +16,10 @@
}
],
"require": {
- "php": "^7.1.3"
+ "php": "^7.1.3",
+ "psr/container": "^1.0"
},
"suggest": {
- "psr/container": "",
"symfony/service-implementation": ""
},
"autoload": {