summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-05-16 11:44:40 +0200
committerRemi Collet <remi@remirepo.net>2019-05-16 11:44:40 +0200
commit3789a60c16f99266088e96ab3a6dd9d60c7895c5 (patch)
tree81f59747e9e36a01ab126f23ea3bf5e09e0a29ec
parent1e2063fc8af7d76b9f652589b3788c025115d00b (diff)
v1.1.0
-rw-r--r--composer.json7
-rw-r--r--php-symfony-contracts.spec16
2 files changed, 17 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index 2f198a0..b83e7c0 100644
--- a/composer.json
+++ b/composer.json
@@ -20,12 +20,15 @@
},
"require-dev": {
"psr/cache": "^1.0",
- "psr/container": "^1.0"
+ "psr/container": "^1.0",
+ "symfony/polyfill-intl-idn": "^1.10"
},
"suggest": {
"psr/cache": "When using the Cache contracts",
"psr/container": "When using the Service contracts",
"symfony/cache-contracts-implementation": "",
+ "symfony/event-dispatcher-implementation": "",
+ "symfony/http-client-contracts-implementation": "",
"symfony/service-contracts-implementation": "",
"symfony/translation-contracts-implementation": ""
},
@@ -38,7 +41,7 @@
"minimum-stability": "dev",
"extra": {
"branch-alias": {
- "dev-master": "1.0-dev"
+ "dev-master": "1.1-dev"
}
}
}
diff --git a/php-symfony-contracts.spec b/php-symfony-contracts.spec
index 1dcd78e..fee1791 100644
--- a/php-symfony-contracts.spec
+++ b/php-symfony-contracts.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 1aa7ab2429c3d594dd70689604b5cf7421254cdf
+%global gh_commit d3636025e8253c6144358ec0a62773cae588395b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner symfony
%global gh_project contracts
@@ -21,7 +21,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{pk_vendor}-%{pk_project}
-Version: 1.0.2
+Version: 1.1.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: A set of abstractions extracted out of the Symfony
@@ -34,12 +34,14 @@ BuildArch: noarch
# For tests
BuildRequires: php(language) >= 7.1.3
BuildRequires: php-reflection
+BuildRequires: php-json
BuildRequires: php-pcre
BuildRequires: php-spl
BuildRequires: php-intl
# From composer.json, "require-dev": {
# "psr/cache": "^1.0",
-# "psr/container": "^1.0"
+# "psr/container": "^1.0",
+# "symfony/polyfill-intl-idn": "^1.10"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >=8
BuildRequires: (php-composer(psr/cache) >= 1.0 with php-composer(psr/cache) < 2)
@@ -62,6 +64,8 @@ Requires: php(language) >= 7.1.3
# "psr/cache": "When using the Cache contracts",
# "psr/container": "When using the Service contracts",
# "symfony/cache-contracts-implementation": "",
+# "symfony/event-dispatcher-implementation": "",
+# "symfony/http-client-contracts-implementation": "",
# "symfony/service-contracts-implementation": "",
# "symfony/translation-contracts-implementation": ""
# remirepo:1
@@ -70,8 +74,9 @@ Recommends: (php-composer(psr/cache) >= 1.0 with php-composer(psr/cache)
Recommends: (php-composer(psr/container) >= 1.0 with php-composer(psr/container) < 2)
# remirepo:1
%endif
-# From phpcompatinfo report for version 1.0.2
+# From phpcompatinfo report for version 1.1.0
Requires: php-reflection
+Requires: php-json
Requires: php-pcre
Requires: php-spl
Requires: php-intl
@@ -150,5 +155,8 @@ exit $ret
%changelog
+* Thu May 16 2019 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+
* Mon Jan 7 2019 Remi Collet <remi@remirepo.net> - 1.0.2-1
- initial package, version 1.0.2