summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-10-19 16:53:41 +0200
committerRemi Collet <remi@php.net>2021-10-19 16:53:41 +0200
commitae4f1cabf3efc35009ae0229a65c2f52a22f671f (patch)
tree1b9fb390a37bd59ff6b308dc18fec155a2465173
parent205d68a8faec85e5b848935ca479a59ccab64cfb (diff)
update to 6.3.0
-rw-r--r--composer.json6
-rw-r--r--php-swiftmailer6.spec11
2 files changed, 11 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index 31d05fd..546b3a1 100644
--- a/composer.json
+++ b/composer.json
@@ -23,7 +23,7 @@
},
"require-dev": {
"mockery/mockery": "^1.0",
- "symfony/phpunit-bridge": "^4.4|^5.0"
+ "symfony/phpunit-bridge": "^4.4|^5.4"
},
"suggest": {
"ext-intl": "Needed to support internationalized email addresses"
@@ -38,5 +38,7 @@
"branch-alias": {
"dev-master": "6.2-dev"
}
- }
+ },
+ "minimum-stability": "dev",
+ "prefer-stable": true
}
diff --git a/php-swiftmailer6.spec b/php-swiftmailer6.spec
index 63b4db9..37508d8 100644
--- a/php-swiftmailer6.spec
+++ b/php-swiftmailer6.spec
@@ -9,7 +9,7 @@
%bcond_without tests
-%global gh_commit 15f7faf8508e04471f666633addacf54c0ab5933
+%global gh_commit 8a5d5072dca8f48460fce2f4131fcc495eec654c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner swiftmailer
%global gh_project swiftmailer
@@ -18,7 +18,7 @@
%global php_home %{_datadir}/php
Name: php-%{gh_project}%{major}
-Version: 6.2.7
+Version: 6.3.0
Release: 1%{?dist}
Summary: Free Feature-rich PHP Mailer
@@ -53,7 +53,7 @@ BuildRequires: php-pcre
BuildRequires: php-spl
# From composer.json, "require-dev": {
# "mockery/mockery": "^1.0",
-# "symfony/phpunit-bridge": "^4.4|^5.0"
+# "symfony/phpunit-bridge": "^4.4|^5.4"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(mockery/mockery) >= 1.0 with php-composer(mockery/mockery) < 2)
@@ -174,7 +174,7 @@ sed -e '/listener/d' phpunit.xml.dist > phpunit.xml
: Run upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --exclude smoke --verbose || ret=1
@@ -196,6 +196,9 @@ exit $ret
%changelog
+* Tue Oct 19 2021 Remi Collet <remi@remirepo.net> - 6.3.0-1
+- update to 6.3.0
+
* Tue Mar 9 2021 Remi Collet <remi@remirepo.net> - 6.2.7-1
- update to 6.2.7
- allow egulias/email-validator v3