summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-10-04 13:15:58 +0200
committerRemi Collet <remi@remirepo.net>2017-10-04 13:15:58 +0200
commit54251ae60915173d15546d0dcb080292f523f235 (patch)
tree18b3cef33981df302ee96bb864d9dd514441f058
dup php-swiftmailer
-rw-r--r--Makefile4
-rw-r--r--composer.json37
-rw-r--r--php-swiftmailer.spec185
3 files changed, 226 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..8335f58
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,37 @@
+{
+ "name": "swiftmailer/swiftmailer",
+ "type": "library",
+ "description": "Swiftmailer, free feature-rich PHP mailer",
+ "keywords": ["mail","mailer","email"],
+ "homepage": "http://swiftmailer.org",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Chris Corbyn"
+ },
+ {
+ "name": "Fabien Potencier",
+ "email": "fabien@symfony.com"
+ }
+ ],
+ "require": {
+ "php": ">=5.3.3"
+ },
+ "require-dev": {
+ "mockery/mockery": "~0.9.1",
+ "symfony/phpunit-bridge": "~3.2"
+ },
+ "autoload": {
+ "files": ["lib/swift_required.php"]
+ },
+ "autoload-dev": {
+ "psr-0": {
+ "Swift_": "tests/unit"
+ }
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "5.4-dev"
+ }
+ }
+}
diff --git a/php-swiftmailer.spec b/php-swiftmailer.spec
new file mode 100644
index 0000000..4dcc066
--- /dev/null
+++ b/php-swiftmailer.spec
@@ -0,0 +1,185 @@
+# remirepo/fedora spec file for php-swiftmailer
+#
+# Copyright (c) 2016-2017 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please preserve changelog entries
+#
+%global gh_commit 9a06dc570a0367850280eefd3f1dc2da45aef517
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner swiftmailer
+%global gh_project swiftmailer
+%global with_tests 0%{!?_without_tests:1}
+%global php_home %{_datadir}/php
+
+Name: php-%{gh_project}
+Version: 5.4.8
+Release: 3%{?dist}
+Summary: Free Feature-rich PHP Mailer
+
+Group: Development/Libraries
+License: MIT
+URL: http://www.swiftmailer.org/
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+
+BuildArch: noarch
+%if %{with_tests}
+BuildRequires: php-reflection
+BuildRequires: php-simplexml
+BuildRequires: php-bcmath
+BuildRequires: php-ctype
+BuildRequires: php-date
+BuildRequires: php-hash
+BuildRequires: php-iconv
+BuildRequires: php-mbstring
+BuildRequires: php-mhash
+BuildRequires: php-openssl
+BuildRequires: php-pcre
+BuildRequires: php-spl
+BuildRequires: php-composer(phpunit/phpunit)
+BuildRequires: php-fedora-autoloader-devel
+# From composer.json, "require-dev": {
+# "mockery/mockery": "~0.9.1",
+# "symfony/phpunit-bridge": "~3.2"
+BuildRequires: php-composer(mockery/mockery) >= 0.9.1
+# ignore minimal version as test suite passes with 2.8
+BuildRequires: php-composer(symfony/phpunit-bridge)
+%endif
+
+# From composer.json, "require": {
+# "php": ">=5.3.3"
+Requires: php(language) >= 5.3.3
+# from phpcompatinfo report on version 5.4.8
+Requires: php-reflection
+Requires: php-simplexml
+Requires: php-bcmath
+Requires: php-ctype
+Requires: php-date
+Requires: php-hash
+Requires: php-iconv
+Requires: php-mbstring
+Requires: php-mhash
+Requires: php-openssl
+Requires: php-pcre
+Requires: php-spl
+
+# Removed from official repo in Fedora 25
+%if 1
+Obsoletes: php-swift-Swift <= 5.4.1
+# Single package in this channel
+Obsoletes: php-channel-swift <= 1.3
+Provides: php-pear(pear.swiftmailer.org/Swift) = %{version}
+%endif
+
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+Swift Mailer integrates into any web app written in PHP, offering a
+flexible and elegant object-oriented approach to sending emails with
+a multitude of features.
+
+Autoloader: %{php_home}/Swift/swift_required.php
+
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+# Install using the same layout than the old PEAR package
+mv lib/swift_required_pear.php lib/swift_required.php
+rm lib/swiftmailer_generate_mimes_config.php
+
+
+%build
+# Empty build section, most likely nothing required.
+
+
+%install
+mkdir -p %{buildroot}/%{php_home}/Swift
+cp -p lib/*.php %{buildroot}/%{php_home}/Swift/
+cp -pr lib/classes/* %{buildroot}/%{php_home}/Swift/
+cp -pr lib/dependency_maps %{buildroot}/%{php_home}/Swift/
+
+
+%check
+%if %{with_tests}
+: Use installed tree and autoloader
+mkdir vendor
+%{_bindir}/phpab --format fedora --output vendor/autoload.php tests
+cat << 'EOF' | tee -a vendor/autoload.php
+require_once '%{buildroot}/%{php_home}/Swift/swift_required.php';
+require_once '%{php_home}/Mockery/autoload.php';
+if (file_exists('%{php_home}/Symfony3/Bridge/PhpUnit')) {
+ \Fedora\Autoloader\Autoload::addPsr4('Symfony\\Bridge\\PhpUnit\\', '%{php_home}/Symfony3/Bridge/PhpUnit');
+} else {
+ \Fedora\Autoloader\Autoload::addPsr4('Symfony\\Bridge\\PhpUnit\\', '%{php_home}/Symfony/Bridge/PhpUnit');
+}
+EOF
+
+TMPDIR=$(mktemp -d $PWD/rpmtests-XXXXXXXX)
+cat << EOF | tee tests/acceptance.conf.php
+<?php
+define('SWIFT_TMP_DIR', '$TMPDIR');
+EOF
+
+: Run upstream test suite
+ret=0
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --exclude smoke --verbose || ret=1
+ fi
+done
+rm -r $TMPDIR
+exit $ret
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc CHANGES README
+%doc doc
+%doc composer.json
+%{php_home}/Swift
+
+
+%changelog
+* Wed Oct 4 2017 Remi Collet <remi@remirepo.net> - 5.4.8-3
+- drop unneeded dependency on php-mcrypt
+
+* Wed May 10 2017 Remi Collet <remi@remirepo.net> - 5.4.8-1
+- Update to 5.4.8
+
+* Fri Apr 21 2017 Remi Collet <remi@remirepo.net> - 5.4.7-1
+- Update to 5.4.7
+
+* Mon Feb 13 2017 Remi Collet <remi@fedoraproject.org> - 5.4.6-1
+- update to 5.4.6
+
+* Thu Dec 29 2016 Remi Collet <remi@fedoraproject.org> - 5.4.5-1
+- update to 5.4.5
+- fix Remote Code Execution CVE-2016-10074
+
+* Thu Nov 24 2016 Remi Collet <remi@fedoraproject.org> - 5.4.4-1
+- update to 5.4.4
+
+* Fri Jul 8 2016 Remi Collet <remi@fedoraproject.org> - 5.4.3-1
+- update to 5.4.3
+- drop patch merged upstream
+
+* Tue Jun 14 2016 Remi Collet <remi@fedoraproject.org> - 5.4.2-2
+- add patch to allow mockery 0.9.x
+ open https://github.com/swiftmailer/swiftmailer/pull/769
+
+* Mon May 2 2016 Remi Collet <remi@fedoraproject.org> - 5.4.2-1
+- update to 5.4.2
+
+* Fri Mar 25 2016 Remi Collet <remi@fedoraproject.org> - 5.4.1-2
+- rebuild for remi repository
+
+* Fri Oct 16 2015 Remi Collet <remi@fedoraproject.org> - 5.4.1-1
+- initial rpm, version 5.4.1
+- sources from github, pear channel is dead
+