summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json36
-rw-r--r--php-swiftmailer.spec15
-rw-r--r--swiftmailer-upstream.patch80
3 files changed, 42 insertions, 89 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..0549006
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,36 @@
+{
+ "name": "swiftmailer/swiftmailer",
+ "type": "library",
+ "description": "Swiftmailer, free feature-rich PHP mailer",
+ "keywords": ["mail","mailer","email"],
+ "homepage": "http://swiftmailer.org",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Chris Corbyn"
+ },
+ {
+ "name": "Fabien Potencier",
+ "email": "fabien@symfony.com"
+ }
+ ],
+ "require": {
+ "php": ">=5.3.3"
+ },
+ "require-dev": {
+ "mockery/mockery": "~0.9.1,<0.9.4"
+ },
+ "autoload": {
+ "files": ["lib/swift_required.php"]
+ },
+ "autoload-dev": {
+ "psr-0": {
+ "Swift_": "tests/unit"
+ }
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "5.4-dev"
+ }
+ }
+}
diff --git a/php-swiftmailer.spec b/php-swiftmailer.spec
index 05454f4..bf36910 100644
--- a/php-swiftmailer.spec
+++ b/php-swiftmailer.spec
@@ -6,7 +6,7 @@
#
# Please preserve changelog entries
#
-%global gh_commit 0697e6aa65c83edf97bb0f23d8763f94e3f11421
+%global gh_commit d8db871a54619458a805229a057ea2af33c753e8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner swiftmailer
%global gh_project swiftmailer
@@ -14,8 +14,8 @@
%global php_home %{_datadir}/php
Name: php-%{gh_project}
-Version: 5.4.1
-Release: 2%{?dist}
+Version: 5.4.2
+Release: 1%{?dist}
Summary: Free Feature-rich PHP Mailer
Group: Development/Libraries
@@ -23,10 +23,6 @@ License: MIT
URL: http://www.swiftmailer.org/
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
-# Upstream patches
-# Fix test bootstrap and disable gc to avoid segfault
-Patch0: %{gh_project}-upstream.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
@@ -77,8 +73,6 @@ Autoloader: %{php_home}/Swift/swift_required.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
-
# Install using the same layout than the old PEAR package
mv lib/swift_required_pear.php lib/swift_required.php
rm lib/swiftmailer_generate_mimes_config.php
@@ -154,6 +148,9 @@ rm -rf %{buildroot}
%changelog
+* Mon May 2 2016 Remi Collet <remi@fedoraproject.org> - 5.4.2-1
+- update to 5.4.2
+
* Fri Mar 25 2016 Remi Collet <remi@fedoraproject.org> - 5.4.1-2
- rebuild for remi repository
diff --git a/swiftmailer-upstream.patch b/swiftmailer-upstream.patch
deleted file mode 100644
index 68611ed..0000000
--- a/swiftmailer-upstream.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-From 94a0f8bffb1f6832fe97e4c9c67c4852fe55e2a3 Mon Sep 17 00:00:00 2001
-From: Christian Schmidt <cs@blackwoodseven.com>
-Date: Thu, 25 Jun 2015 21:43:00 +0200
-Subject: [PATCH] Do not assume that require_once returns an object
-
----
- composer.json | 5 +++++
- tests/bootstrap.php | 3 +--
- 2 files changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/composer.json b/composer.json
-index a7b5e44..0549006 100644
---- a/composer.json
-+++ b/composer.json
-@@ -23,6 +23,11 @@
- "autoload": {
- "files": ["lib/swift_required.php"]
- },
-+ "autoload-dev": {
-+ "psr-0": {
-+ "Swift_": "tests/unit"
-+ }
-+ },
- "extra": {
- "branch-alias": {
- "dev-master": "5.4-dev"
-diff --git a/tests/bootstrap.php b/tests/bootstrap.php
-index 9b169b3..55538bb 100644
---- a/tests/bootstrap.php
-+++ b/tests/bootstrap.php
-@@ -1,7 +1,6 @@
- <?php
-
--$autoloader = require_once dirname(__DIR__).'/vendor/autoload.php';
--$autoloader->add('Swift_', __DIR__.'/unit');
-+require_once dirname(__DIR__).'/vendor/autoload.php';
-
- set_include_path(get_include_path().PATH_SEPARATOR.dirname(__DIR__).'/lib');
-
-From 5174336501b554dce18f304af74c4440d4b78c9d Mon Sep 17 00:00:00 2001
-From: Hugo Hamon <hugo.hamon@sensiolabs.com>
-Date: Sun, 23 Aug 2015 12:09:17 +0200
-Subject: [PATCH] Added PHP 5.6, PHP 7 and HHVM to the build matrix.
-
----
- .travis.yml | 22 +++++++++++-----------
- phpunit.xml.dist | 2 +-
- tests/bootstrap.php | 5 ++++-
- 3 files changed, 16 insertions(+), 13 deletions(-)
-
-diff --git a/phpunit.xml.dist b/phpunit.xml.dist
-index 2420586..0d3e698 100644
---- a/phpunit.xml.dist
-+++ b/phpunit.xml.dist
-@@ -32,6 +32,6 @@
- </testsuites>
-
- <listeners>
-- <listener class="\Mockery\Adapter\Phpunit\TestListener"></listener>
-+ <listener class="Mockery\Adapter\Phpunit\TestListener"/>
- </listeners>
- </phpunit>
-diff --git a/tests/bootstrap.php b/tests/bootstrap.php
-index 55538bb..34f56b5 100644
---- a/tests/bootstrap.php
-+++ b/tests/bootstrap.php
-@@ -2,9 +2,12 @@
-
- require_once dirname(__DIR__).'/vendor/autoload.php';
-
-+// Disable garbage collector to prevent segfaults
-+gc_disable();
-+
- set_include_path(get_include_path().PATH_SEPARATOR.dirname(__DIR__).'/lib');
-
--\Mockery::getConfiguration()->allowMockingNonExistentMethods(false);
-+Mockery::getConfiguration()->allowMockingNonExistentMethods(false);
-
- if (is_file(__DIR__.'/acceptance.conf.php')) {
- require_once __DIR__.'/acceptance.conf.php';