summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-07-08 17:35:17 +0200
committerRemi Collet <fedora@famillecollet.com>2016-07-08 17:35:17 +0200
commite50c6991d8866c22731b09b5e2854bd32f9cda3e (patch)
tree09fb87a0353b394c547c6d9e21d88f152747e470
parent12debc4c7ada68434de0ace3f766cbc528671884 (diff)
php-swiftmailer: 5.4.3
-rw-r--r--composer.json2
-rw-r--r--php-swiftmailer-mockery.patch62
-rw-r--r--php-swiftmailer.spec32
3 files changed, 15 insertions, 81 deletions
diff --git a/composer.json b/composer.json
index 0549006..86691bd 100644
--- a/composer.json
+++ b/composer.json
@@ -18,7 +18,7 @@
"php": ">=5.3.3"
},
"require-dev": {
- "mockery/mockery": "~0.9.1,<0.9.4"
+ "mockery/mockery": "~0.9.1"
},
"autoload": {
"files": ["lib/swift_required.php"]
diff --git a/php-swiftmailer-mockery.patch b/php-swiftmailer-mockery.patch
deleted file mode 100644
index eae9ca5..0000000
--- a/php-swiftmailer-mockery.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-From 9470303d8da535053c9ebd85d40feeb75b07307e Mon Sep 17 00:00:00 2001
-From: Remi Collet <fedora@famillecollet.com>
-Date: Tue, 14 Jun 2016 13:40:19 +0200
-Subject: [PATCH] allow latest mockery 0.9.x
-
----
- composer.json | 2 +-
- tests/bootstrap.php | 2 +-
- tests/smoke/Swift/Smoke/AttachmentSmokeTest.php | 1 +
- tests/smoke/Swift/Smoke/InternationalSmokeTest.php | 1 +
- 4 files changed, 4 insertions(+), 2 deletions(-)
-
-diff --git a/composer.json b/composer.json
-index 0549006..86691bd 100644
---- a/composer.json
-+++ b/composer.json
-@@ -18,7 +18,7 @@
- "php": ">=5.3.3"
- },
- "require-dev": {
-- "mockery/mockery": "~0.9.1,<0.9.4"
-+ "mockery/mockery": "~0.9.1"
- },
- "autoload": {
- "files": ["lib/swift_required.php"]
-diff --git a/tests/bootstrap.php b/tests/bootstrap.php
-index 34f56b5..27091a2 100644
---- a/tests/bootstrap.php
-+++ b/tests/bootstrap.php
-@@ -7,7 +7,7 @@
-
- set_include_path(get_include_path().PATH_SEPARATOR.dirname(__DIR__).'/lib');
-
--Mockery::getConfiguration()->allowMockingNonExistentMethods(false);
-+Mockery::getConfiguration()->allowMockingNonExistentMethods(true);
-
- if (is_file(__DIR__.'/acceptance.conf.php')) {
- require_once __DIR__.'/acceptance.conf.php';
-diff --git a/tests/smoke/Swift/Smoke/AttachmentSmokeTest.php b/tests/smoke/Swift/Smoke/AttachmentSmokeTest.php
-index d0054d6..c3b61c3 100644
---- a/tests/smoke/Swift/Smoke/AttachmentSmokeTest.php
-+++ b/tests/smoke/Swift/Smoke/AttachmentSmokeTest.php
-@@ -9,6 +9,7 @@ class Swift_Smoke_AttachmentSmokeTest extends SwiftMailerSmokeTestCase
-
- public function setUp()
- {
-+ parent::setup(); // For skip
- $this->_attFile = __DIR__.'/../../../_samples/files/textfile.zip';
- }
-
-diff --git a/tests/smoke/Swift/Smoke/InternationalSmokeTest.php b/tests/smoke/Swift/Smoke/InternationalSmokeTest.php
-index 66e37ec..fafd727 100644
---- a/tests/smoke/Swift/Smoke/InternationalSmokeTest.php
-+++ b/tests/smoke/Swift/Smoke/InternationalSmokeTest.php
-@@ -9,6 +9,7 @@ class Swift_Smoke_InternationalSmokeTest extends SwiftMailerSmokeTestCase
-
- public function setUp()
- {
-+ parent::setup(); // For skip
- $this->_attFile = __DIR__.'/../../../_samples/files/textfile.zip';
- }
-
diff --git a/php-swiftmailer.spec b/php-swiftmailer.spec
index 39e5922..c6af8ce 100644
--- a/php-swiftmailer.spec
+++ b/php-swiftmailer.spec
@@ -6,7 +6,7 @@
#
# Please preserve changelog entries
#
-%global gh_commit d8db871a54619458a805229a057ea2af33c753e8
+%global gh_commit 4cc92842069c2bbc1f28daaaf1d2576ec4dfe153
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner swiftmailer
%global gh_project swiftmailer
@@ -14,8 +14,8 @@
%global php_home %{_datadir}/php
Name: php-%{gh_project}
-Version: 5.4.2
-Release: 2%{?dist}
+Version: 5.4.3
+Release: 1%{?dist}
Summary: Free Feature-rich PHP Mailer
Group: Development/Libraries
@@ -23,16 +23,13 @@ License: MIT
URL: http://www.swiftmailer.org/
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
-# https://github.com/swiftmailer/swiftmailer/pull/769
-Patch0: %{name}-mockery.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
BuildRequires: php-composer(phpunit/phpunit)
BuildRequires: php-composer(theseer/autoload)
# From composer.json, "require-dev": {
-# "mockery/mockery": "~0.9.1,<0.9.4"
+# "mockery/mockery": "~0.9.1"
BuildRequires: php-composer(mockery/mockery) >= 0.9.1
%endif
@@ -75,8 +72,6 @@ Autoloader: %{php_home}/Swift/swift_required.php
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
-
# Install using the same layout than the old PEAR package
mv lib/swift_required_pear.php lib/swift_required.php
rm lib/swiftmailer_generate_mimes_config.php
@@ -111,24 +106,21 @@ cat << EOF | tee tests/acceptance.conf.php
define('SWIFT_TMP_DIR', '$TMPDIR');
EOF
+: Run upstream test suite
ret=0
+# remirepo:10
run=0
-
-# with mockobject 3.1.0
-# PHPUnit_Framework_MockObject_RuntimeException: Trying to configure method "sendPerformed"
-# which cannot be configured because it does not exist, has not been specified, is final, or is static
-
-: Run upstream test suite
if which php56; then
php56 %{_bindir}/phpunit --exclude smoke --verbose || ret=1
run=1
fi
-if which php70; then
- php70 %{_bindir}/phpunit --exclude smoke --verbose || : ignore PHP 7 test results
+if which php71; then
+ php71 %{_bindir}/phpunit --exclude smoke --verbose || ret=1
run=1
fi
if [ $run -eq 0 ]; then
- %{_bindir}/phpunit --exclude smoke --verbose || ret=1
+%{_bindir}/phpunit --exclude smoke --verbose || ret=1
+# remirepo:1
fi
# Cleanup
@@ -152,6 +144,10 @@ rm -rf %{buildroot}
%changelog
+* Fri Jul 8 2016 Remi Collet <remi@fedoraproject.org> - 5.4.3-1
+- update to 5.4.2
+- drop patch merged upstream
+
* Tue Jun 14 2016 Remi Collet <remi@fedoraproject.org> - 5.4.2-2
- add patch to allow mockery 0.9.x
open https://github.com/swiftmailer/swiftmailer/pull/769