summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-07 12:24:25 +0100
committerRemi Collet <remi@remirepo.net>2017-11-07 12:24:25 +0100
commit94e826c2b5e47b3847a40ba0af557e91c4783b38 (patch)
tree99bd3a6deb877b47602e917aaf7ca439493a5b20
parenta51b0ae0ebd8ffa63787f6da51ef1563f5a7a0e1 (diff)
fix FTBFS from Koschei
add version constraint for symfony/phpunit-bridge
-rw-r--r--php-swiftmailer.spec38
1 files changed, 30 insertions, 8 deletions
diff --git a/php-swiftmailer.spec b/php-swiftmailer.spec
index 7748c76..76f8619 100644
--- a/php-swiftmailer.spec
+++ b/php-swiftmailer.spec
@@ -15,7 +15,7 @@
Name: php-%{gh_project}
Version: 5.4.8
-Release: 1%{?dist}
+Release: 4%{?dist}
Summary: Free Feature-rich PHP Mailer
Group: Development/Libraries
@@ -25,32 +25,43 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
%if %{with_tests}
+BuildRequires: php-reflection
+BuildRequires: php-simplexml
+BuildRequires: php-bcmath
+BuildRequires: php-ctype
+BuildRequires: php-date
+BuildRequires: php-hash
+BuildRequires: php-iconv
+BuildRequires: php-mbstring
+BuildRequires: php-mhash
+BuildRequires: php-openssl
+BuildRequires: php-pcre
+BuildRequires: php-spl
BuildRequires: php-composer(phpunit/phpunit)
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require-dev": {
# "mockery/mockery": "~0.9.1",
# "symfony/phpunit-bridge": "~3.2"
BuildRequires: php-composer(mockery/mockery) >= 0.9.1
-# SF3 don't provides this package for now
-BuildRequires: php-composer(symfony/phpunit-bridge) < 3
+# ignore minimal version as test suite passes with 2.8
+BuildRequires: php-composer(symfony/phpunit-bridge) < 4
%endif
# From composer.json, "require": {
# "php": ">=5.3.3"
Requires: php(language) >= 5.3.3
-# from phpcompatinfo report on version 5.4.1
+# from phpcompatinfo report on version 5.4.8
+Requires: php-reflection
+Requires: php-simplexml
Requires: php-bcmath
Requires: php-ctype
Requires: php-date
Requires: php-hash
Requires: php-iconv
Requires: php-mbstring
-Requires: php-mcrypt
Requires: php-mhash
Requires: php-openssl
Requires: php-pcre
-Requires: php-reflection
-Requires: php-simplexml
Requires: php-spl
# Removed from official repo in Fedora 25
@@ -100,7 +111,11 @@ mkdir vendor
cat << 'EOF' | tee -a vendor/autoload.php
require_once '%{buildroot}/%{php_home}/Swift/swift_required.php';
require_once '%{php_home}/Mockery/autoload.php';
-\Fedora\Autoloader\Autoload::addPsr4('Symfony\\Bridge\\PhpUnit\\', '%{php_home}/Symfony/Bridge/PhpUnit');
+if (file_exists('%{php_home}/Symfony3/Bridge/PhpUnit')) {
+ \Fedora\Autoloader\Autoload::addPsr4('Symfony\\Bridge\\PhpUnit\\', '%{php_home}/Symfony3/Bridge/PhpUnit');
+} else {
+ \Fedora\Autoloader\Autoload::addPsr4('Symfony\\Bridge\\PhpUnit\\', '%{php_home}/Symfony/Bridge/PhpUnit');
+}
EOF
TMPDIR=$(mktemp -d $PWD/rpmtests-XXXXXXXX)
@@ -131,6 +146,13 @@ exit $ret
%changelog
+* Tue Nov 7 2017 Remi Collet <remi@remirepo.net> - 5.4.8-4
+- fix FTBFS from Koschei
+- add version constraint for symfony/phpunit-bridge
+
+* Wed Oct 4 2017 Remi Collet <remi@remirepo.net> - 5.4.8-3
+- drop unneeded dependency on php-mcrypt
+
* Wed May 10 2017 Remi Collet <remi@remirepo.net> - 5.4.8-1
- Update to 5.4.8