summaryrefslogtreecommitdiffstats
path: root/php-swaggest-json-schema.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-swaggest-json-schema.spec')
-rw-r--r--php-swaggest-json-schema.spec20
1 files changed, 12 insertions, 8 deletions
diff --git a/php-swaggest-json-schema.spec b/php-swaggest-json-schema.spec
index 46f6acd..f829c17 100644
--- a/php-swaggest-json-schema.spec
+++ b/php-swaggest-json-schema.spec
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit 1d7cce2dac6844a8a612672ad5936e8c4145e96a
+%global gh_commit ab7cca149a5822acc5be538dd6c008a348f6cb89
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner swaggest
%global gh_project php-json-schema
@@ -23,7 +23,7 @@
%global major %nil
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 0.12.37
+Version: 0.12.38
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: High definition PHP structures with JSON-schema based validation
@@ -39,10 +39,10 @@ BuildRequires: php-json
BuildRequires: php-mbstring
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(phplang/scope-exit) >= 1.0 with php-composer(phplang/scope-exit) < 2)
-BuildRequires: (php-composer(swaggest/json-diff) >= 3.5.1 with php-composer(swaggest/json-diff) < 4)
+BuildRequires: (php-composer(swaggest/json-diff) >= 3.8.2 with php-composer(swaggest/json-diff) < 4)
%else
BuildRequires: php-phplang-scope-exit >= 1.0
-BuildRequires: php-swaggest-json-diff >= 3.5.1
+BuildRequires: php-swaggest-json-diff >= 3.8.2
%endif
# For tests, from composer.json "require-dev": {
# "phpunit/phpunit": "^5",
@@ -63,16 +63,16 @@ BuildRequires: php-fedora-autoloader-devel
# "ext-json": "*",
# "ext-mbstring": "*",
# "phplang/scope-exit": "^1.0",
-# "swaggest/json-diff": "^3.5.1"
+# "swaggest/json-diff": "^3.8.2"
Requires: php(language) >= 5.4
Requires: php-json
Requires: php-mbstring
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(phplang/scope-exit) >= 1.0 with php-composer(phplang/scope-exit) < 2)
-Requires: (php-composer(swaggest/json-diff) >= 3.5.1 with php-composer(swaggest/json-diff) < 4)
+Requires: (php-composer(swaggest/json-diff) >= 3.8.2 with php-composer(swaggest/json-diff) < 4)
%else
Requires: php-phplang-scope-exit >= 1.0
-Requires: php-swaggest-json-diff >= 3.5.1
+Requires: php-swaggest-json-diff >= 3.8.2
%endif
# From phpcompatinfo report for 0.12.17
Requires: php-date
@@ -130,7 +130,7 @@ EOF
# Skip online tests: testInvalid, testValidate
ret=0
-for cmd in php php73 php74 php80; do
+for cmd in php php73 php74 php80 php81; do
if which $cmd; then
$cmd %{phpunit} \
--no-coverage \
@@ -155,6 +155,10 @@ exit $ret
%changelog
+* Wed Sep 22 2021 Remi Collet <remi@remirepo.net> - 0.12.38-1
+- update to 0.12.38
+- raise dependency on swaggest/json-diff 3.8.2
+
* Thu Sep 2 2021 Remi Collet <remi@remirepo.net> - 0.12.37-1
- update to 0.12.37