summaryrefslogtreecommitdiffstats
path: root/php-swaggest-json-schema.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-06-17 14:50:21 +0200
committerRemi Collet <remi@remirepo.net>2021-06-17 14:50:21 +0200
commit0248e881dc8ff00bb14fa35d23fb35a0fb89495e (patch)
tree8c9c56781bbb1229bde1aec27744069147047839 /php-swaggest-json-schema.spec
parentae10e344db46b6ed8433c309ac1af3071a94a857 (diff)
update to 0.12.34
Diffstat (limited to 'php-swaggest-json-schema.spec')
-rw-r--r--php-swaggest-json-schema.spec13
1 files changed, 10 insertions, 3 deletions
diff --git a/php-swaggest-json-schema.spec b/php-swaggest-json-schema.spec
index 92ed57b..1f43965 100644
--- a/php-swaggest-json-schema.spec
+++ b/php-swaggest-json-schema.spec
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit 87919a4564b9682c4c4328d00ba28f9f631b0bbc
+%global gh_commit ec9085579a2ba10be7e083116556332d45355206
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner swaggest
%global gh_project php-json-schema
@@ -23,7 +23,7 @@
%global major %nil
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 0.12.33
+Version: 0.12.34
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: High definition PHP structures with JSON-schema based validation
@@ -128,10 +128,14 @@ require '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}/autoload
\Fedora\Autoloader\Autoload::addPsr4('%{ns_vendor}\\%{ns_project}\\Tests\\', dirname(__DIR__).'/tests/src');
EOF
+# Skip online tests: testInvalid, testValidate
ret=0
for cmd in php php73 php74 php80; do
if which $cmd; then
- $cmd %{phpunit} --no-coverage --verbose || ret=1
+ $cmd %{phpunit} \
+ --no-coverage \
+ --filter '^((?!(SwaggerTest::testInvalid|SwaggerTest::testValidate)).)*$' \
+ --verbose || ret=1
fi
done
exit $ret
@@ -151,6 +155,9 @@ exit $ret
%changelog
+* Thu Jun 17 2021 Remi Collet <remi@remirepo.net> - 0.12.34-1
+- update to 0.12.34
+
* Mon May 31 2021 Remi Collet <remi@remirepo.net> - 0.12.33-1
- update to 0.12.33