summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-12 10:36:16 +0200
committerRemi Collet <remi@php.net>2022-09-12 10:36:16 +0200
commit0ad7c7ac45e2d274762965e197444b0a8a2e3080 (patch)
treed355478162c99bc786ecf4802846e1abd04e1c9f
parent1e5a115c8eedc56d3fd04880203fe611b528deb4 (diff)
update to 3.9.0
-rw-r--r--composer.json2
-rw-r--r--php-swaggest-json-diff.spec15
2 files changed, 10 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index bb0ce49..9a47543 100644
--- a/composer.json
+++ b/composer.json
@@ -13,7 +13,7 @@
"ext-json": "*"
},
"require-dev": {
- "phpunit/phpunit": "^4.8.23"
+ "phperf/phpunit": "4.8.37"
},
"autoload": {
"psr-4": {
diff --git a/php-swaggest-json-diff.spec b/php-swaggest-json-diff.spec
index 53b70d8..b8faf37 100644
--- a/php-swaggest-json-diff.spec
+++ b/php-swaggest-json-diff.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-swaggest-json-diff
#
-# Copyright (c) 2019-2021 Remi Collet
+# Copyright (c) 2019-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -10,7 +10,7 @@
%bcond_without tests
# Github
-%global gh_commit bb3e3b4e9d842bb2e48f31ea568d0459968d1d42
+%global gh_commit ff3a7921e9f1aa096067eb541fcfd0e7611c558c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner swaggest
%global gh_project json-diff
@@ -23,7 +23,7 @@
%global major %nil
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 3.8.3
+Version: 3.9.0
Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: JSON diff/rearrange/patch/pointer library for PHP
@@ -36,8 +36,8 @@ BuildArch: noarch
%if %{with tests}
BuildRequires: php-json
# For tests, from composer.json "require-dev": {
-# "phpunit/phpunit": "^4.8.23"
-BuildRequires: php-composer(phpunit/phpunit) >= 4.8.23
+# "phpunit/phpunit": "4.8.37"
+BuildRequires: php-composer(phpunit/phpunit) >= 4.8.37
%global phpunit %{_bindir}/phpunit
BuildRequires: php-filter
BuildRequires: php-pcre
@@ -89,7 +89,7 @@ require '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}%{major}/autoload
EOF
ret=0
-for cmd in php php73 php74 php80 php81; do
+for cmd in php php74 php80 php81 php82; do
if which $cmd; then
$cmd %{phpunit} --no-coverage --verbose || ret=1
fi
@@ -112,6 +112,9 @@ exit $ret
%changelog
+* Mon Sep 12 2022 Remi Collet <remi@remirepo.net> - 3.9.0-1
+- update to 3.9.0
+
* Mon Sep 27 2021 Remi Collet <remi@remirepo.net> - 3.8.3-1
- update to 3.8.3