summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-06-17 08:50:04 +0200
committerRemi Collet <fedora@famillecollet.com>2015-06-17 08:50:04 +0200
commitb047a2d827e7cb6207636b83212d78609a5dc4cf (patch)
tree10aadd10f9777304ccd21ca4d7b6e1e94aaf4219
parent6af863bb71c01dbbb3d01d4ebe879de5d0b3d466 (diff)
php-stack-builder: add backport stuff for remirepo
-rw-r--r--Makefile4
-rw-r--r--php-stack-builder.spec12
2 files changed, 16 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/php-stack-builder.spec b/php-stack-builder.spec
index 064b8d9..92a6e7e 100644
--- a/php-stack-builder.spec
+++ b/php-stack-builder.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-stack-builder, from Fedora:
#
# RPM spec file for php-stack-builder
#
@@ -42,6 +43,7 @@ URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
BuildArch: noarch
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
# For autoload generation
BuildRequires: %{_bindir}/phpab
# For tests
@@ -101,6 +103,8 @@ AUTOLOAD
%install
+rm -rf %{buildroot}
+
mkdir -p %{buildroot}%{phpdir}
cp -rp src/* %{buildroot}%{phpdir}/
@@ -120,7 +124,12 @@ BOOTSTRAP
%endif
+%clean
+rm -rf %{buildroot}
+
+
%files
+%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -132,5 +141,8 @@ BOOTSTRAP
%changelog
+* Wed Jun 17 2015 Remi Collet <remi@remirepo.net> - 1.0.3-1
+- add backport stuff for remirepo
+
* Sat May 16 2015 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.0.3-1
- Initial package