summaryrefslogtreecommitdiffstats
path: root/php-simplesamlphp-saml2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-simplesamlphp-saml2.spec')
-rw-r--r--php-simplesamlphp-saml2.spec28
1 files changed, 16 insertions, 12 deletions
diff --git a/php-simplesamlphp-saml2.spec b/php-simplesamlphp-saml2.spec
index b348eb1..95d7f36 100644
--- a/php-simplesamlphp-saml2.spec
+++ b/php-simplesamlphp-saml2.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-simplesamlphp-saml2
#
-# Copyright (c) 2016-2018 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2016-2020 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner simplesamlphp
%global github_name saml2
-%global github_version 2.3.8
-%global github_commit 5d69753a61b4bfb95eed3ea0c3f8cbb4e6e0ad2f
+%global github_version 2.3.9
+%global github_commit 452217ceae817c712237556f36cc07ec680a21ff
%global composer_vendor simplesamlphp
%global composer_project saml2
@@ -27,21 +27,20 @@
# NOTE: Min version not 1.0 because autoloader required
%global psr_log_min_ver 1.0.1
%global psr_log_max_ver 2.0
-# "robrichards/xmlseclibs": "^2.0"
-%global robrichards_xmlseclibs_min_ver 2.0
+# "robrichards/xmlseclibs": "^2.1.1"
+%global robrichards_xmlseclibs_min_ver 2.1.1
%global robrichards_xmlseclibs_max_ver 3.0
-# Build using "--without tests" to disable tests
-%global with_tests 0%{!?_without_tests:1}
+# Build using "--with tests" to enable tests
+%global with_tests 0%{?_with_tests:1}
%{!?phpdir: %global phpdir %{_datadir}/php}
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 2%{?github_release}%{?dist}
+Release: 1%{?github_release}%{?dist}
Summary: SAML2 PHP library from SimpleSAMLphp
-Group: Development/Libraries
License: LGPLv2+
URL: https://github.com/%{github_owner}/%{github_name}
@@ -70,7 +69,7 @@ BuildRequires: php-openssl
BuildRequires: php-composer(mockery/mockery) < %{mockery_max_ver}
BuildRequires: php-composer(mockery/mockery) >= %{mockery_min_ver}
%endif
-## phpcompatinfo (computed from version 2.3.8)
+## phpcompatinfo (computed from version 2.3.9)
BuildRequires: php-date
BuildRequires: php-libxml
BuildRequires: php-mcrypt
@@ -95,7 +94,7 @@ Requires: php-composer(psr/log) >= %{psr_log_min_ver}
Requires: php-composer(robrichards/xmlseclibs) < %{robrichards_xmlseclibs_max_ver}
Requires: php-composer(robrichards/xmlseclibs) >= %{robrichards_xmlseclibs_min_ver}
%endif
-# phpcompatinfo (computed from version 2.3.8)
+# phpcompatinfo (computed from version 2.3.9)
Requires: php-date
Requires: php-libxml
Requires: php-pcre
@@ -171,7 +170,7 @@ sed 's/function testToString/function SKIP_testToString/' \
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in "" %{?rhel:php54 php55 php56} php70 php71 php72; do
+for PHP_EXEC in "" %{?rhel:php54 php55 php56 php70 php71} php72 php73 php74; do
if [ -z "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose --configuration=tools/phpunit \
|| RETURN_CODE=1
@@ -192,6 +191,11 @@ exit $RETURN_CODE
%changelog
+* Sat Feb 22 2020 Shawn Iwinski <shawn@iwin.ski> - 2.3.9-1
+- Update to 2.3.9
+- Fix FTBFS (RHBZ #1799879)
+- Disable tests by default
+
* Mon Mar 12 2018 Shawn Iwinski <shawn@iwin.ski> - 2.3.8-2
- Update range dependencies' conditional to include RHEL 8+