summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-05-04 09:54:31 +0200
committerRemi Collet <fedora@famillecollet.com>2015-05-04 09:54:31 +0200
commitbef3f78602c9eba5568c8a8e2a0e14326a91989c (patch)
tree59b61169cf229fa027c5b8483f2d35b5dd2f3f07
php-seld-phar-utils: 1.0.0 - New package
-rw-r--r--Makefile10
-rw-r--r--php-seld-phar-utils.spec73
2 files changed, 83 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed
diff --git a/php-seld-phar-utils.spec b/php-seld-phar-utils.spec
new file mode 100644
index 0000000..2fdf41c
--- /dev/null
+++ b/php-seld-phar-utils.spec
@@ -0,0 +1,73 @@
+# spec file for php-seld-phar-utils
+#
+# Copyright (c) 2015 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit 336bb5ee20de511f3c1a164222fcfd194afcab3a
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner Seldaek
+%global gh_project phar-utils
+
+Name: php-seld-phar-utils
+Version: 1.0.0
+Release: 1%{?dist}
+Summary: PHAR file format utilities
+
+Group: Development/Libraries
+License: MIT
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php(language) >= 5.3
+
+# From composer.json
+# "php": ">=5.3.0",
+Requires: php(language) >= 5.3.0
+# From phpcompatifo report for 1.0.0
+Requires: php-date
+Requires: php-hash
+Requires: php-pcre
+Requires: php-spl
+
+Provides: php-composer(seld/phar-utils) = %{version}
+
+
+%description
+PHAR file format utilities, for when PHP phars you up.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+# Nothing
+
+
+%install
+rm -rf %{buildroot}
+# Restore PSR-0 tree
+mkdir -p %{buildroot}%{_datadir}/php/Seld/PharUtils/
+cp -pr src/* %{buildroot}%{_datadir}/php/Seld/PharUtils/
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc README.md composer.json
+%{_datadir}/php/Seld
+
+
+%changelog
+* Mon May 4 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- initial package \ No newline at end of file