summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-05-04 10:02:27 +0200
committerRemi Collet <fedora@famillecollet.com>2015-05-04 10:02:27 +0200
commit86f09d7be4666093aee7595e775de93e0d18272d (patch)
tree8c91cd10b4d56d6ff2a7669f90a77bc47d146532
php-seld-cli-prompt: 1.0.0 - New package
-rw-r--r--Makefile10
-rw-r--r--php-seld-cli-prompt.spec74
2 files changed, 84 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed
diff --git a/php-seld-cli-prompt.spec b/php-seld-cli-prompt.spec
new file mode 100644
index 0000000..faedd79
--- /dev/null
+++ b/php-seld-cli-prompt.spec
@@ -0,0 +1,74 @@
+# spec file for php-seld-cli-prompt
+#
+# Copyright (c) 2015 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global gh_commit fe114c7a6ac5cb0ce76932ae4017024d9842a49c
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner Seldaek
+%global gh_project cli-prompt
+
+Name: php-seld-cli-prompt
+Version: 1.0.0
+Release: 1%{?dist}
+Summary: Allows you to prompt for user input on the command line
+
+Group: Development/Libraries
+License: MIT
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php(language) >= 5.3
+
+# From composer.json
+# "php": ">=5.3.0",
+Requires: php(language) >= 5.3.0
+# From phpcompatifo report for 1.0.0
+Requires: php-pcre
+Requires: php-spl
+
+Provides: php-composer(seld/cli-prompt) = %{version}
+
+
+%description
+While prompting for user input using fgets() is quite easy, sometimes you
+need to prompt for sensitive information. In these cases, the characters typed
+in by the user should not be directly visible, and this is quite a pain to do
+in a cross-platform way.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+# Nothing
+
+
+%install
+rm -rf %{buildroot}
+# Restore PSR-0 tree
+mkdir -p %{buildroot}%{_datadir}/php/Seld/CliPrompt
+cp -pr src/* %{buildroot}%{_datadir}/php/Seld/CliPrompt/
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc README.md composer.json res/example.php
+%{_datadir}/php/Seld
+
+
+%changelog
+* Mon May 4 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- initial package \ No newline at end of file