summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-sebastian-type4.spec12
1 files changed, 8 insertions, 4 deletions
diff --git a/php-sebastian-type4.spec b/php-sebastian-type4.spec
index 0d279c4..1f2dfe3 100644
--- a/php-sebastian-type4.spec
+++ b/php-sebastian-type4.spec
@@ -7,8 +7,7 @@
# Please, preserve the changelog entries
#
-# disable until phpunit10 available
-%bcond_with tests
+%bcond_without tests
# github
%global gh_commit 462699a16464c3944eefc02ebdd77882bd3925bf
@@ -26,7 +25,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Version: 4.0.0
-Release: 1%{?dist}
+Release: 3%{?dist}
Summary: Collection of value objects that represent the types of the PHP type system, v%{major}
License: BSD-3-Clause
@@ -61,6 +60,8 @@ Collection of value objects that represent the types of the PHP type system.
This package provides version %{major} of %{pk_vendor}/%{pk_project} library.
+Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php
+
%prep
%setup -q -n %{gh_project}-%{gh_commit}
@@ -91,7 +92,7 @@ EOF
: Run upstream test suite
ret=0
-for cmd in php php81 php82; do
+for cmd in php php81 php82 php83; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
%{_bindir}/phpunit10 || ret=1
@@ -114,6 +115,9 @@ exit $ret
%changelog
+* Wed Aug 23 2023 Remi Collet <remi@remirepo.net> - 4.0.0-3
+- Enable test suite
+
* Fri Feb 3 2023 Remi Collet <remi@remirepo.net> - 4.0.0-1
- update to 4.0.0
- raise dependency on PHP 8.1