summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-03 11:23:48 +0100
committerRemi Collet <remi@php.net>2023-02-03 11:23:48 +0100
commit259761b98aee3b2f77fc63daef1811ee7e554f5b (patch)
tree78714f0a35260fdcf19bbe2fd8882a73625be60c
parentb55a3d55d88d955d6ade7364f8e4204db2a51f40 (diff)
update to 4.0.0
raise dependency on PHP 8.1 rename to php-sebastian-type4 move to /usr/share/php/SebastianBergmann/Type4
-rw-r--r--composer.json8
-rw-r--r--php-sebastian-type4.spec34
2 files changed, 24 insertions, 18 deletions
diff --git a/composer.json b/composer.json
index a0865c9..faf8a0e 100644
--- a/composer.json
+++ b/composer.json
@@ -16,14 +16,14 @@
},
"prefer-stable": true,
"require": {
- "php": ">=7.3"
+ "php": ">=8.1"
},
"require-dev": {
- "phpunit/phpunit": "^9.5"
+ "phpunit/phpunit": "^10.0"
},
"config": {
"platform": {
- "php": "7.3.0"
+ "php": "8.1.0"
},
"optimize-autoloader": true,
"sort-packages": true
@@ -44,7 +44,7 @@
},
"extra": {
"branch-alias": {
- "dev-master": "3.2-dev"
+ "dev-main": "4.0-dev"
}
}
}
diff --git a/php-sebastian-type4.spec b/php-sebastian-type4.spec
index 1e5c985..a3cf2d9 100644
--- a/php-sebastian-type4.spec
+++ b/php-sebastian-type4.spec
@@ -1,4 +1,4 @@
-# remirepo/fedora spec file for php-sebastian-type3
+# remirepo/fedora spec file for php-sebastian-type4
#
# Copyright (c) 2019-2023 Remi Collet
# License: CC-BY-SA-4.0
@@ -7,24 +7,25 @@
# Please, preserve the changelog entries
#
-%bcond_without tests
+# disable until phpunit10 available
+%bcond_with tests
# github
-%global gh_commit 75e2c2a32f5e0b3aef905b9ed0b179b953b3d7c7
+%global gh_commit 462699a16464c3944eefc02ebdd77882bd3925bf
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project type
# packagist
%global pk_vendor sebastian
%global pk_project %{gh_project}
-%global major 3
+%global major 4
# namespace
%global php_home %{_datadir}/php
%global ns_vendor SebastianBergmann
%global ns_project Type
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 3.2.1
+Version: 4.0.0
Release: 1%{?dist}
Summary: Collection of value objects that represent the types of the PHP type system, v%{major}
@@ -34,22 +35,21 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
-BuildRequires: php(language) >= 7.3
+BuildRequires: php(language) >= 8.1
BuildRequires: php-reflection
# Autoloader
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
%if %{with tests}
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^9.5"
-BuildRequires: phpunit9 >= 9.5
+# "phpunit/phpunit": "^10.0"
+BuildRequires: phpunit10
%endif
# from composer.json, "require": {
-# "php": ">=7.3",
-Requires: php(language) >= 7.3
-# from phpcompatinfo report for version 1.0.0
+# "php": ">=8.1",
+Requires: php(language) >= 8.1
+# from phpcompatinfo report for version 4.0.0
Requires: php-reflection
-Requires: php-spl
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -91,10 +91,10 @@ EOF
: Run upstream test suite
ret=0
-for cmd in php php80 php81 php82; do
+for cmd in php php81 php82; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit9 \
+ %{_bindir}/phpunit10 \
--verbose || ret=1
fi
done
@@ -115,6 +115,12 @@ exit $ret
%changelog
+* Fri Feb 3 2023 Remi Collet <remi@remirepo.net> - 4.0.0-1
+- update to 4.0.0
+- raise dependency on PHP 8.1
+- rename to php-sebastian-type4
+- move to /usr/share/php/SebastianBergmann/Type4
+
* Fri Feb 3 2023 Remi Collet <remi@remirepo.net> - 3.2.1-1
- update to 3.2.1