summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-03-15 15:00:34 +0100
committerRemi Collet <remi@php.net>2022-03-15 15:00:34 +0100
commit9b4d16604af12216567c8762567f80e0578e3505 (patch)
tree4dfbca560d4fcceaf745a62429fcf25fbd5173be
duplicate v2
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--composer.json49
-rw-r--r--php-sebastian-type3.spec160
4 files changed, 222 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..b02d8e9
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,49 @@
+{
+ "name": "sebastian/type",
+ "description": "Collection of value objects that represent the types of the PHP type system",
+ "type": "library",
+ "homepage": "https://github.com/sebastianbergmann/type",
+ "license": "BSD-3-Clause",
+ "authors": [
+ {
+ "name": "Sebastian Bergmann",
+ "email": "sebastian@phpunit.de",
+ "role": "lead"
+ }
+ ],
+ "support": {
+ "issues": "https://github.com/sebastianbergmann/type/issues"
+ },
+ "prefer-stable": true,
+ "require": {
+ "php": ">=7.3"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^9.3"
+ },
+ "config": {
+ "platform": {
+ "php": "7.3.0"
+ },
+ "optimize-autoloader": true,
+ "sort-packages": true
+ },
+ "autoload": {
+ "classmap": [
+ "src/"
+ ]
+ },
+ "autoload-dev": {
+ "classmap": [
+ "tests/_fixture"
+ ],
+ "files": [
+ "tests/_fixture/callback_function.php"
+ ]
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.3-dev"
+ }
+ }
+}
diff --git a/php-sebastian-type3.spec b/php-sebastian-type3.spec
new file mode 100644
index 0000000..19007e7
--- /dev/null
+++ b/php-sebastian-type3.spec
@@ -0,0 +1,160 @@
+# remirepo/fedora spec file for php-sebastian-type2
+#
+# Copyright (c) 2019-2021 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+%bcond_without tests
+
+# github
+%global gh_commit b8cd8a1c753c90bc1a0f5372170e3e489136f914
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner sebastianbergmann
+%global gh_project type
+# packagist
+%global pk_vendor sebastian
+%global pk_project %{gh_project}
+%global major 2
+# namespace
+%global php_home %{_datadir}/php
+%global ns_vendor SebastianBergmann
+%global ns_project Type
+
+Name: php-%{pk_vendor}-%{pk_project}%{major}
+Version: 2.3.4
+Release: 1%{?dist}
+Summary: Collection of value objects that represent the types of the PHP type system, version %{major}
+
+License: BSD
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+BuildRequires: php(language) >= 7.3
+BuildRequires: php-reflection
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel >= 1.0.0
+%if %{with tests}
+# from composer.json, "require-dev": {
+# "phpunit/phpunit": "^9.3"
+BuildRequires: phpunit9 >= 9.3
+%endif
+
+# from composer.json, "require": {
+# "php": ">=7.3",
+Requires: php(language) >= 7.3
+# from phpcompatinfo report for version 1.0.0
+Requires: php-reflection
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
+
+
+%description
+Collection of value objects that represent the types of the PHP type system.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+# Generate the Autoloader
+phpab --template fedora --output src/autoload.php src
+
+# For the test suite
+phpab --template fedora --output tests/autoload.php tests/_fixture/
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
+cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
+
+
+%check
+%if %{with tests}
+mkdir vendor
+cat <<EOF | tee vendor/autoload.php
+<?php
+require_once 'tests/autoload.php';
+require_once 'tests/_fixture/callback_function.php';
+EOF
+
+: Run upstream test suite
+ret=0
+for cmd in php php73 php74 php80 php81; do
+ if which $cmd; then
+ $cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
+ %{_bindir}/phpunit9 \
+ --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: bootstrap build with test suite disabled
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%dir %{php_home}/%{ns_vendor}
+ %{php_home}/%{ns_vendor}/%{ns_project}%{major}
+
+
+%changelog
+* Tue Jun 15 2021 Remi Collet <remi@remirepo.net> - 2.3.4-1
+- update to 2.3.4
+
+* Fri Jun 4 2021 Remi Collet <remi@remirepo.net> - 2.3.2-1
+- update to 2.3.2
+
+* Mon Oct 26 2020 Remi Collet <remi@remirepo.net> - 2.3.1-1
+- update to 2.3.1
+
+* Tue Oct 6 2020 Remi Collet <remi@remirepo.net> - 2.3.0-1
+- update to 2.3.0
+
+* Mon Sep 28 2020 Remi Collet <remi@remirepo.net> - 2.2.2-1
+- update to 2.2.2 (no change)
+
+* Mon Jul 6 2020 Remi Collet <remi@remirepo.net> - 2.2.1-1
+- update to 2.2.1
+
+* Mon Jun 29 2020 Remi Collet <remi@remirepo.net> - 2.1.1-1
+- update to 2.1.1
+
+* Tue Jun 2 2020 Remi Collet <remi@remirepo.net> - 2.1.0-1
+- update to 2.1.0
+- sources from git snapshot
+- switch to phpunit9
+
+* Fri Feb 7 2020 Remi Collet <remi@remirepo.net> - 2.0.0-1
+- update to 2.0.0
+- raise dependency on PHP 7.3
+- rename to php-sebastian-type2
+- move to /usr/share/php/SebastianBergmann/Type2
+
+* Tue Jul 2 2019 Remi Collet <remi@remirepo.net> - 1.1.3-1
+- update to 1.1.3
+
+* Wed Jun 19 2019 Remi Collet <remi@remirepo.net> - 1.1.2-1
+- update to 1.1.2
+
+* Sat Jun 8 2019 Remi Collet <remi@remirepo.net> - 1.1.1-1
+- update to 1.1.1
+
+* Sat Jun 8 2019 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+
+* Fri Jun 7 2019 Remi Collet <remi@remirepo.net> - 1.0.0-1
+- initial package