summaryrefslogtreecommitdiffstats
path: root/php-sebastian-type2.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-06-02 07:19:20 +0200
committerRemi Collet <remi@remirepo.net>2020-06-02 07:19:20 +0200
commita094a9846ee4b344b5ba7c97098d0a77048d1179 (patch)
tree8035f9ea56a82651b0444f9969353161b4a4de90 /php-sebastian-type2.spec
parent6be59e98f4c68a810c99803cefd5113465069234 (diff)
update to 2.1.0
sources from git snapshot switch to phpunit9
Diffstat (limited to 'php-sebastian-type2.spec')
-rw-r--r--php-sebastian-type2.spec22
1 files changed, 14 insertions, 8 deletions
diff --git a/php-sebastian-type2.spec b/php-sebastian-type2.spec
index c21ddbd..b258c0e 100644
--- a/php-sebastian-type2.spec
+++ b/php-sebastian-type2.spec
@@ -8,7 +8,7 @@
#
%global bootstrap 0
# github
-%global gh_commit 9e8f42f740afdea51f5f4e8cec2035580e797ee1
+%global gh_commit bad49207c6f854e7a25cef0ea948ac8ebe3ef9d8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project type
@@ -27,13 +27,14 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 2.0.0
+Version: 2.1.0
Release: 1%{?dist}
Summary: Collection of value objects that represent the types of the PHP type system
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php(language) >= 7.3
@@ -42,9 +43,9 @@ BuildRequires: php-reflection
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
%if %{with_tests}
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^9.0"
-# ignore min version, test suite passes with 8.1
-BuildRequires: phpunit8 > 8.1
+# "phpunit/phpunit": "^9.2"
+# ignore min version, test suite passes with 9.1
+BuildRequires: phpunit9
%endif
# from composer.json, "require": {
@@ -91,10 +92,10 @@ EOF
: Run upstream test suite
ret=0
-for cmd in php php73 php74; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit8 --verbose || ret=1
+ %{_bindir}/phpunit9 --verbose || ret=1
fi
done
exit $ret
@@ -114,6 +115,11 @@ exit $ret
%changelog
+* Tue Jun 2 2020 Remi Collet <remi@remirepo.net> - 2.1.0-1
+- update to 2.1.0
+- sources from git snapshot
+- switch to phpunit9
+
* Fri Feb 7 2020 Remi Collet <remi@remirepo.net> - 2.0.0-1
- update to 2.0.0
- raise dependency on PHP 7.3