summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-02-07 15:27:27 +0100
committerRemi Collet <remi@remirepo.net>2020-02-07 15:27:27 +0100
commitd2903dec04b50891dc6afec95b0c4d974656ec98 (patch)
treebf0dc5ca1ef209f8a67946efd032e58aec0690e6
duplicate v1
-rw-r--r--.gitignore8
-rw-r--r--Makefile4
-rw-r--r--composer.json49
-rw-r--r--php-sebastian-type2.spec128
4 files changed, 189 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..5fc9c5e
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,49 @@
+{
+ "name": "sebastian/type",
+ "description": "Collection of value objects that represent the types of the PHP type system",
+ "type": "library",
+ "homepage": "https://github.com/sebastianbergmann/type",
+ "license": "BSD-3-Clause",
+ "authors": [
+ {
+ "name": "Sebastian Bergmann",
+ "email": "sebastian@phpunit.de",
+ "role": "lead"
+ }
+ ],
+ "support": {
+ "issues": "https://github.com/sebastianbergmann/type/issues"
+ },
+ "prefer-stable": true,
+ "require": {
+ "php": "^7.2"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^8.2"
+ },
+ "config": {
+ "platform": {
+ "php": "7.2.0"
+ },
+ "optimize-autoloader": true,
+ "sort-packages": true
+ },
+ "autoload": {
+ "classmap": [
+ "src/"
+ ]
+ },
+ "autoload-dev": {
+ "classmap": [
+ "tests/_fixture"
+ ],
+ "files": [
+ "tests/_fixture/callback_function.php"
+ ]
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.1-dev"
+ }
+ }
+}
diff --git a/php-sebastian-type2.spec b/php-sebastian-type2.spec
new file mode 100644
index 0000000..51fd2bb
--- /dev/null
+++ b/php-sebastian-type2.spec
@@ -0,0 +1,128 @@
+# remirepo/fedora spec file for php-sebastian-type
+#
+# Copyright (c) 2019 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+# github
+%global gh_commit 3aaaa15fa71d27650d62a948be022fe3b48541a3
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner sebastianbergmann
+%global gh_project type
+# packagist
+%global pk_vendor sebastian
+%global pk_project %{gh_project}
+%global major %nil
+# namespace
+%global php_home %{_datadir}/php
+%global ns_vendor SebastianBergmann
+%global ns_project Type
+%if %{bootstrap}
+%global with_tests 0%{?_with_tests:1}
+%else
+%global with_tests 0%{!?_without_tests:1}
+%endif
+
+Name: php-%{pk_vendor}-%{pk_project}%{major}
+Version: 1.1.3
+Release: 1%{?dist}
+Summary: Collection of value objects that represent the types of the PHP type system
+
+License: BSD
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+
+BuildArch: noarch
+BuildRequires: php(language) >= 7.2
+BuildRequires: php-reflection
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel >= 1.0.0
+%if %{with_tests}
+# from composer.json, "require-dev": {
+# "phpunit/phpunit": "^8.2"
+# ignore min version, test suite passes with 8.1
+BuildRequires: phpunit8 > 8.1
+%endif
+
+# from composer.json, "require": {
+# "php": "^7.2",
+Requires: php(language) >= 7.2
+# from phpcompatinfo report for version 1.0.0: only core
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
+
+
+%description
+Collection of value objects that represent the types of the PHP type system.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+# Generate the Autoloader
+phpab --template fedora --output src/autoload.php src
+
+# For the test suite
+phpab --template fedora --output tests/autoload.php tests/_fixture/
+
+
+%install
+mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
+cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat <<EOF | tee vendor/autoload.php
+<?php
+require_once 'tests/autoload.php';
+require_once 'tests/_fixture/callback_function.php';
+EOF
+
+: Run upstream test suite
+ret=0
+for cmd in php php72 php73 php74; do
+ if which $cmd; then
+ $cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
+ %{_bindir}/phpunit8 --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: bootstrap build with test suite disabled
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%dir %{php_home}/%{ns_vendor}
+ %{php_home}/%{ns_vendor}/%{ns_project}%{major}
+
+
+%changelog
+* Tue Jul 2 2019 Remi Collet <remi@remirepo.net> - 1.1.3-1
+- update to 1.1.3
+
+* Wed Jun 19 2019 Remi Collet <remi@remirepo.net> - 1.1.2-1
+- update to 1.1.2
+
+* Sat Jun 8 2019 Remi Collet <remi@remirepo.net> - 1.1.1-1
+- update to 1.1.1
+
+* Sat Jun 8 2019 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+
+* Fri Jun 7 2019 Remi Collet <remi@remirepo.net> - 1.0.0-1
+- initial package