summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-09-28 10:41:07 +0200
committerRemi Collet <remi@remirepo.net>2020-09-28 10:41:07 +0200
commit8f1bae24693ede03cf48a9e70677ed2c57065e67 (patch)
tree39f8bc9a948ac732190552d9ad8ba5790baa196f
parentab6c3ada04a83959aa3e6e0b3b5ed8cd31f3ff57 (diff)
update to 2.2.2 (no change)
-rw-r--r--composer.json4
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-sebastian-type2.spec25
3 files changed, 42 insertions, 15 deletions
diff --git a/composer.json b/composer.json
index ee414e7..c8d9720 100644
--- a/composer.json
+++ b/composer.json
@@ -16,10 +16,10 @@
},
"prefer-stable": true,
"require": {
- "php": "^7.3 || ^8.0"
+ "php": ">=7.3"
},
"require-dev": {
- "phpunit/phpunit": "^9.2"
+ "phpunit/phpunit": "^9.3"
},
"config": {
"platform": {
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..4190c13
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs --exclude tools $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-sebastian-type2.spec b/php-sebastian-type2.spec
index d079a30..1feb47c 100644
--- a/php-sebastian-type2.spec
+++ b/php-sebastian-type2.spec
@@ -6,9 +6,11 @@
#
# Please, preserve the changelog entries
#
-%global bootstrap 0
+
+%bcond_without tests
+
# github
-%global gh_commit 86991e2b33446cd96e648c18bcdb1e95afb2c05a
+%global gh_commit e494dcaeb89d1458c9ccd8c819745245a1669aea
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project type
@@ -20,16 +22,11 @@
%global php_home %{_datadir}/php
%global ns_vendor SebastianBergmann
%global ns_project Type
-%if %{bootstrap}
-%bcond_with tests
-%else
-%bcond_without tests
-%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 2.2.1
+Version: 2.2.2
Release: 1%{?dist}
-Summary: Collection of value objects that represent the types of the PHP type system
+Summary: Collection of value objects that represent the types of the PHP type system, version %{major}
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -43,13 +40,12 @@ BuildRequires: php-reflection
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
%if %{with tests}
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^9.2"
-# ignore min version, test suite passes with 9.1
-BuildRequires: phpunit9
+# "phpunit/phpunit": "^9.3"
+BuildRequires: phpunit9 >= 9.3
%endif
# from composer.json, "require": {
-# "php": "^7.3 || ^8.0",
+# "php": ">=7.3",
Requires: php(language) >= 7.3
# from phpcompatinfo report for version 1.0.0
Requires: php-reflection
@@ -115,6 +111,9 @@ exit $ret
%changelog
+* Mon Sep 28 2020 Remi Collet <remi@remirepo.net> - 2.2.2-1
+- update to 2.2.2 (no change)
+
* Mon Jul 6 2020 Remi Collet <remi@remirepo.net> - 2.2.1-1
- update to 2.2.1