summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-06-29 08:11:30 +0200
committerRemi Collet <remi@remirepo.net>2020-06-29 08:11:30 +0200
commit49ad9847acbd18fefe5141a07f856ee11f08893b (patch)
tree6ba64b17a990bb72a5dff45a649faed17144e486
parent3abf60e829d76b1aff450bbdddcf708b3fe7659c (diff)
update to 3.0.2 (no change)
-rw-r--r--composer.json2
-rw-r--r--php-sebastian-resource-operations3.spec17
2 files changed, 11 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index f4ed96d..eec7247 100644
--- a/composer.json
+++ b/composer.json
@@ -11,7 +11,7 @@
],
"prefer-stable": true,
"require": {
- "php": "^7.3"
+ "php": "^7.3 || ^8.0"
},
"require-dev": {
"phpunit/phpunit": "^9.0"
diff --git a/php-sebastian-resource-operations3.spec b/php-sebastian-resource-operations3.spec
index 4776d38..0d64b8a 100644
--- a/php-sebastian-resource-operations3.spec
+++ b/php-sebastian-resource-operations3.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 71421c1745788de4facae1b79af923650bd3ec15
+%global gh_commit 0653718a5a629b065e91f774595267f8dc32e213
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
@@ -21,13 +21,13 @@
%global ns_project ResourceOperations
%global major 3
%if %{bootstrap}
-%global with_tests 0%{?_with_tests:1}
+%bcond_with tests
%else
-%global with_tests 0%{!?_without_tests:1}
+%bcond_without tests
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 3.0.1
+Version: 3.0.2
%global specrel 1
Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Provides a list of PHP built-in functions that operate on resources
@@ -40,14 +40,14 @@ Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php(language) >= 7.3
BuildRequires: php-fedora-autoloader-devel
-%if %{with_tests}
+%if %{with tests}
# from composer.json
# "phpunit/phpunit": "^9.0"
BuildRequires: phpunit9
%endif
# from composer.json
-# "php": "^7.3"
+# "php": "^7.3 || ^8.0"
Requires: php(language) >= 7.3
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -79,7 +79,7 @@ cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
%check
-%if %{with_tests}
+%if %{with tests}
mkdir vendor
touch vendor/autoload.php
@@ -106,6 +106,9 @@ exit $ret
%changelog
+* Mon Jun 29 2020 Remi Collet <remi@remirepo.net> - 3.0.2-1
+- update to 3.0.2 (no change)
+
* Tue Jun 16 2020 Remi Collet <remi@remirepo.net> - 3.0.1-1
- update to 3.0.1 (no change)
- sources from git snapshot