summaryrefslogtreecommitdiffstats
path: root/php-sebastian-recursion-context7.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-sebastian-recursion-context7.spec')
-rw-r--r--php-sebastian-recursion-context7.spec37
1 files changed, 21 insertions, 16 deletions
diff --git a/php-sebastian-recursion-context7.spec b/php-sebastian-recursion-context7.spec
index bf62aeb..40bfb29 100644
--- a/php-sebastian-recursion-context7.spec
+++ b/php-sebastian-recursion-context7.spec
@@ -1,4 +1,4 @@
-# remirepo/fedora spec file for php-sebastian-recursion-context6
+# remirepo/fedora spec file for php-sebastian-recursion-context7
#
# SPDX-FileCopyrightText: Copyright 2015-2025 Remi Collet
# SPDX-License-Identifier: CECILL-2.1
@@ -7,26 +7,26 @@
# Please, preserve the changelog entries
#
-# disabled until phpunit11 available
-%bcond_without tests
+# disabled until phpunit12 available
+%bcond_with tests
-%global gh_commit 694d156164372abbd149a4b85ccda2e4670c0e16
+%global gh_commit c405ae3a63e01b32eb71577f8ec1604e39858a7c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project recursion-context
-%global gh_date 2024-07-03
+%global gh_date 2025-02-07
# Packagist
%global pk_vendor sebastian
%global pk_project %{gh_project}
# Namespace
%global ns_vendor SebastianBergmann
%global ns_project RecursionContext
-%global major 6
+%global major 7
%global php_home %{_datadir}/php
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 6.0.2
-Release: 2%{?dist}
+Version: 7.0.0
+Release: 1%{?dist}
Summary: Recursively process PHP variables, version %{major}
License: BSD-3-Clause
@@ -36,19 +36,18 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
BuildArch: noarch
-BuildRequires: php(language) >= 8.2
+BuildRequires: php(language) >= 8.3
BuildRequires: php-fedora-autoloader-devel
%if %{with tests}
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^11.0"
-BuildRequires: phpunit11
+# "phpunit/phpunit": "^12.0"
+BuildRequires: phpunit12
%endif
# from composer.json
-# "php": ">=8.2"
-Requires: php(language) >= 8.2
+# "php": ">=8.3"
+Requires: php(language) >= 8.3
# from phpcompatinfo report for version 5.0.0
-Requires: php-spl
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -84,10 +83,10 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php php82 php83 php84; do
+for cmd in php php83 php84; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit11 || ret=1
+ %{_bindir}/phpunit12 || ret=1
fi
done
exit $ret
@@ -104,6 +103,12 @@ exit $ret
%changelog
+* Fri Feb 7 2025 Remi Collet <remi@remirepo.net> - 7.0.0-1
+- update to 7.0.0
+- raise dependency on PHP 8.3
+- rename to php-sebastian-recursion-context7
+- move to /usr/share/php/SebastianBergmann/RecursionContext7
+
* Tue Feb 4 2025 Remi Collet <remi@remirepo.net> - 6.0.2-2
- enable test suite