summaryrefslogtreecommitdiffstats
path: root/php-sebastian-recursion-context4.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-sebastian-recursion-context4.spec')
-rw-r--r--php-sebastian-recursion-context4.spec50
1 files changed, 31 insertions, 19 deletions
diff --git a/php-sebastian-recursion-context4.spec b/php-sebastian-recursion-context4.spec
index 147dcc7..7cce80a 100644
--- a/php-sebastian-recursion-context4.spec
+++ b/php-sebastian-recursion-context4.spec
@@ -1,19 +1,23 @@
-# remirepo/fedora spec file for php-sebastian-recursion-context3
+# remirepo/fedora spec file for php-sebastian-recursion-context4
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2020 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global bootstrap 1
-%global gh_commit 5b0cd723502bac3b006cbf3dbf7a1e3fcefe4fa8
+%global bootstrap 0
+%global gh_commit cdd86616411fc3062368b720b0425de10bd3d579
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project recursion-context
+# Packagist
%global pk_vendor sebastian
%global pk_project %{gh_project}
-%global major 3
+# Namespace
+%global ns_vendor SebastianBergmann
+%global ns_project RecursionContext
+%global major 4
%global php_home %{_datadir}/php
%if %{bootstrap}
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
@@ -22,7 +26,7 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 3.0.0
+Version: 4.0.0
Release: 1%{?dist}
Summary: Recursively process PHP variables
@@ -31,18 +35,19 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
BuildArch: noarch
-BuildRequires: php(language) >= 7.0
+BuildRequires: php(language) >= 7.3
BuildRequires: php-fedora-autoloader-devel
%if %{with_tests}
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^6.0"
-BuildRequires: phpunit6
+# "phpunit/phpunit": "^9.0"
+# TODO test suite passes with v8, switch to v9 when available
+BuildRequires: phpunit8
%endif
# from composer.json
-# "php": "^7.0"
-Requires: php(language) >= 7.0
-# from phpcompatinfo report for version 3.0.0
+# "php": "^7.3"
+Requires: php(language) >= 7.3
+# from phpcompatinfo report for version 4.0.0
Requires: php-spl
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -64,8 +69,8 @@ Provides functionality to recursively process PHP variables.
%install
-mkdir -p %{buildroot}%{php_home}/SebastianBergmann
-cp -pr src %{buildroot}%{php_home}/SebastianBergmann/RecursionContext%{major}
+mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
+cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
%check
@@ -75,10 +80,10 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php70 php71 php; do
+for cmd in php php73 php74; do
if which $cmd; then
- %{_bindir}/php -d include_path=.:%{buildroot}%{_datadir}/php:%{_datadir}/php \
- %{_bindir}/phpunit6 --verbose || ret=1
+ $cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
+ %{_bindir}/phpunit8 --verbose || ret=1
fi
done
exit $ret
@@ -88,14 +93,21 @@ exit $ret
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc README.md composer.json
-%dir %{php_home}/SebastianBergmann
- %{php_home}/SebastianBergmann/RecursionContext%{major}
+%dir %{php_home}/%{ns_vendor}
+ %{php_home}/%{ns_vendor}/%{ns_project}%{major}
%changelog
+* Fri Feb 7 2020 Remi Collet <remi@remirepo.net> - 4.0.0-1
+- update to 4.0.0
+- raise dependency on PHP 7.3
+- rename to php-sebastian-recursion-context4
+- move to /usr/share/php/SebastianBergmann/RecursionContext4
+
* Fri Mar 3 2017 Remi Collet <remi@remirepo.net> - 3.0.0-1
- update to 3.0.0
- rename to php-sebastian-recursion-context3