summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-sebastian-recursion-context4.spec17
2 files changed, 11 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 1a2d251..291ed5b 100644
--- a/composer.json
+++ b/composer.json
@@ -26,7 +26,7 @@
"sort-packages": true
},
"require": {
- "php": "^7.3"
+ "php": "^7.3 || ^8.0"
},
"require-dev": {
"phpunit/phpunit": "^9.0"
diff --git a/php-sebastian-recursion-context4.spec b/php-sebastian-recursion-context4.spec
index ea019bb..4f8988b 100644
--- a/php-sebastian-recursion-context4.spec
+++ b/php-sebastian-recursion-context4.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit a32789e5f0157c10cf216ce6c5136db12a12b847
+%global gh_commit 062231bf61d2b9448c4fa5a7643b5e1829c11d63
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project recursion-context
@@ -20,13 +20,13 @@
%global major 4
%global php_home %{_datadir}/php
%if %{bootstrap}
-%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+%bcond_with tests
%else
-%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+%bcond_without tests
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 4.0.1
+Version: 4.0.2
Release: 1%{?dist}
Summary: Recursively process PHP variables
@@ -38,14 +38,14 @@ Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php(language) >= 7.3
BuildRequires: php-fedora-autoloader-devel
-%if %{with_tests}
+%if %{with tests}
# from composer.json, "require-dev": {
# "phpunit/phpunit": "^9.0"
BuildRequires: phpunit9
%endif
# from composer.json
-# "php": "^7.3"
+# "php": "^7.3 || ^8.0"
Requires: php(language) >= 7.3
# from phpcompatinfo report for version 4.0.0
Requires: php-spl
@@ -74,7 +74,7 @@ cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
%check
-%if %{with_tests}
+%if %{with tests}
mkdir vendor
touch vendor/autoload.php
@@ -102,6 +102,9 @@ exit $ret
%changelog
+* Mon Jun 29 2020 Remi Collet <remi@remirepo.net> - 4.0.2-1
+- update to 4.0.2
+
* Tue Jun 16 2020 Remi Collet <remi@remirepo.net> - 4.0.1-1
- update to 4.0.1
- sources from git snapshot