summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-09-28 10:35:18 +0200
committerRemi Collet <remi@remirepo.net>2020-09-28 10:35:18 +0200
commit95b6b07954be05293e1d004d2646cdcb212f8167 (patch)
tree14688535e3cee26cd82e690a2917f5acd741cc3f
parent5dbf2164448b4371457d7fdca50bcd1192cc01f0 (diff)
update to 4.0.3
-rw-r--r--composer.json4
-rw-r--r--php-sebastian-recursion-context4.spec24
2 files changed, 14 insertions, 14 deletions
diff --git a/composer.json b/composer.json
index 291ed5b..8a54082 100644
--- a/composer.json
+++ b/composer.json
@@ -26,10 +26,10 @@
"sort-packages": true
},
"require": {
- "php": "^7.3 || ^8.0"
+ "php": ">=7.3"
},
"require-dev": {
- "phpunit/phpunit": "^9.0"
+ "phpunit/phpunit": "^9.3"
},
"autoload": {
"classmap": [
diff --git a/php-sebastian-recursion-context4.spec b/php-sebastian-recursion-context4.spec
index 4f8988b..43b5330 100644
--- a/php-sebastian-recursion-context4.spec
+++ b/php-sebastian-recursion-context4.spec
@@ -6,8 +6,10 @@
#
# Please, preserve the changelog entries
#
-%global bootstrap 0
-%global gh_commit 062231bf61d2b9448c4fa5a7643b5e1829c11d63
+
+%bcond_without tests
+
+%global gh_commit ed8c9cd355089134bc9cba421b5cfdd58f0eaef7
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project recursion-context
@@ -19,16 +21,11 @@
%global ns_project RecursionContext
%global major 4
%global php_home %{_datadir}/php
-%if %{bootstrap}
-%bcond_with tests
-%else
-%bcond_without tests
-%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 4.0.2
+Version: 4.0.3
Release: 1%{?dist}
-Summary: Recursively process PHP variables
+Summary: Recursively process PHP variables, version %{major}
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -40,12 +37,12 @@ BuildRequires: php(language) >= 7.3
BuildRequires: php-fedora-autoloader-devel
%if %{with tests}
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^9.0"
-BuildRequires: phpunit9
+# "phpunit/phpunit": "^9.3"
+BuildRequires: phpunit9 >= 9.3
%endif
# from composer.json
-# "php": "^7.3 || ^8.0"
+# "php": ">=7.3"
Requires: php(language) >= 7.3
# from phpcompatinfo report for version 4.0.0
Requires: php-spl
@@ -102,6 +99,9 @@ exit $ret
%changelog
+* Mon Sep 28 2020 Remi Collet <remi@remirepo.net> - 4.0.3-1
+- update to 4.0.3
+
* Mon Jun 29 2020 Remi Collet <remi@remirepo.net> - 4.0.2-1
- update to 4.0.2