summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-11-30 10:04:07 +0100
committerRemi Collet <remi@remirepo.net>2020-11-30 10:04:07 +0100
commit3bccf9c23b40cf7cf25a8e0d0cc32ca0ecce474e (patch)
tree1d288e79caff4ea1a43252fe91ed72f61aa0f2c7
parentce21b7afebd6109ace6c08aeea35bb6c6fd5f908 (diff)
update to 3.0.1 (no change)
-rw-r--r--composer.json2
-rw-r--r--php-sebastian-recursion-context3.spec14
2 files changed, 9 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index e6456a9..f2bef36 100644
--- a/composer.json
+++ b/composer.json
@@ -18,7 +18,7 @@
}
],
"require": {
- "php": "^7.0"
+ "php": ">=7.0"
},
"require-dev": {
"phpunit/phpunit": "^6.0"
diff --git a/php-sebastian-recursion-context3.spec b/php-sebastian-recursion-context3.spec
index 4d95206..6d2f86f 100644
--- a/php-sebastian-recursion-context3.spec
+++ b/php-sebastian-recursion-context3.spec
@@ -6,8 +6,8 @@
#
# Please, preserve the changelog entries
#
-%global bootstrap 1
-%global gh_commit 5b0cd723502bac3b006cbf3dbf7a1e3fcefe4fa8
+%global bootstrap 0
+%global gh_commit 367dcba38d6e1977be014dc4b22f47a484dac7fb
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project recursion-context
@@ -22,11 +22,10 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 3.0.0
+Version: 3.0.1
Release: 1%{?dist}
Summary: Recursively process PHP variables
-Group: Development/Libraries
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
@@ -41,7 +40,7 @@ BuildRequires: phpunit6
%endif
# from composer.json
-# "php": "^7.0"
+# "php": ">=7.0"
Requires: php(language) >= 7.0
# from phpcompatinfo report for version 3.0.0
Requires: php-spl
@@ -76,7 +75,7 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php70 php71 php; do
+for cmd in php php72 php73 php74 php80; do
if which $cmd; then
%{_bindir}/php -d include_path=.:%{buildroot}%{_datadir}/php:%{_datadir}/php \
%{_bindir}/phpunit6 --verbose || ret=1
@@ -97,6 +96,9 @@ exit $ret
%changelog
+* Mon Nov 30 2020 Remi Collet <remi@remirepo.net> - 3.0.1-1
+- update to 3.0.1 (no change)
+
* Fri Mar 3 2017 Remi Collet <remi@remirepo.net> - 3.0.0-1
- update to 3.0.0
- rename to php-sebastian-recursion-context3