summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-03 15:16:16 +0100
committerRemi Collet <fedora@famillecollet.com>2017-03-03 15:16:16 +0100
commit05107ac8d971345dbc16f77b6d89b09bc62e43e6 (patch)
treec970a391f5b3e6c8b1b797143f020bf8975d845e
php-sebastian-recursion-context3: 3.0.0 - New package
-rw-r--r--Makefile4
-rw-r--r--composer.json36
-rw-r--r--php-sebastian-recursion-context3.spec133
3 files changed, 173 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..e6456a9
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,36 @@
+{
+ "name": "sebastian/recursion-context",
+ "description": "Provides functionality to recursively process PHP variables",
+ "homepage": "http://www.github.com/sebastianbergmann/recursion-context",
+ "license": "BSD-3-Clause",
+ "authors": [
+ {
+ "name": "Sebastian Bergmann",
+ "email": "sebastian@phpunit.de"
+ },
+ {
+ "name": "Jeff Welch",
+ "email": "whatthejeff@gmail.com"
+ },
+ {
+ "name": "Adam Harvey",
+ "email": "aharvey@php.net"
+ }
+ ],
+ "require": {
+ "php": "^7.0"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^6.0"
+ },
+ "autoload": {
+ "classmap": [
+ "src/"
+ ]
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "3.0.x-dev"
+ }
+ }
+}
diff --git a/php-sebastian-recursion-context3.spec b/php-sebastian-recursion-context3.spec
new file mode 100644
index 0000000..5147d90
--- /dev/null
+++ b/php-sebastian-recursion-context3.spec
@@ -0,0 +1,133 @@
+# remirepo/fedora spec file for php-sebastian-recursion-context3
+#
+# Copyright (c) 2015-2017 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%global bootstrap 0
+%global gh_commit 5b0cd723502bac3b006cbf3dbf7a1e3fcefe4fa8
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner sebastianbergmann
+%global gh_project recursion-context
+%global pk_vendor sebastian
+%global pk_project %{gh_project}
+%global php_home %{_datadir}/php
+%global major 3
+%if %{bootstrap}
+%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
+%else
+%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
+%endif
+
+Name: php-%{pk_vendor}-%{pk_project}%{major}
+Version: 3.0.0
+Release: 1%{?dist}
+Summary: Recursively process PHP variables
+
+Group: Development/Libraries
+License: BSD
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php(language) >= 7.0
+BuildRequires: php-fedora-autoloader-devel
+%if %{with_tests}
+# from composer.json, "require-dev": {
+# "phpunit/phpunit": "^6.0"
+BuildRequires: phpunit6
+%endif
+
+# from composer.json
+# "php": "^7.0"
+Requires: php(language) >= 7.0
+# from phpcompatinfo report for version 3.0.0
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{pk_vendor}-%{pk_project}) = %{version}
+
+
+%description
+Provides functionality to recursively process PHP variables.
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+# Generate the Autoloader
+%{_bindir}/phpab --template fedora --output src/autoload.php src
+
+
+%install
+rm -rf %{buildroot}
+mkdir -p %{buildroot}%{php_home}/SebastianBergmann
+cp -pr src %{buildroot}%{php_home}/SebastianBergmann/RecursionContext%{major}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+touch vendor/autoload.php
+
+: Run upstream test suite
+ret=0
+for cmd in php70 php71 php; do
+ if which $cmd; then
+ %{_bindir}/php -d include_path=.:%{buildroot}%{_datadir}/php:%{_datadir}/php \
+ %{_bindir}/phpunit6 --verbose || ret=1
+ fi
+done
+exit $ret
+%else
+: bootstrap build with test suite disabled
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc README.md composer.json
+%dir %{php_home}/SebastianBergmann
+ %{php_home}/SebastianBergmann/RecursionContext%{major}
+
+
+%changelog
+* Fri Mar 3 2017 Remi Collet <remi@remirepo.net> - 3.0.0-1
+- update to 3.0.0
+- rename to php-sebastian-recursion-context3
+- raise dependency on PHP 7
+
+* Tue Nov 22 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
+- update to 2.0.0 (no change)
+
+* Tue Nov 15 2016 Remi Collet <remi@fedoraproject.org> - 1.0.4-1
+- update to 1.0.4
+
+* Mon Nov 14 2016 Remi Collet <remi@fedoraproject.org> - 1.0.3-1
+- update to 1.0.3
+
+* Mon Oct 31 2016 Remi Collet <remi@fedoraproject.org> - 1.0.2-3
+- switch to fedora/autoloader
+
+* Tue Dec 8 2015 Remi Collet <remi@fedoraproject.org> - 1.0.2-1
+- update to 1.0.2
+- drop dependency on hash extension
+- run test suite with both php 5 and 7 when available
+
+* Sun Jul 26 2015 Remi Collet <remi@fedoraproject.org> - 1.0.1-1
+- update to 1.0.1 (only CS)
+
+* Sat Jan 24 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- initial package