summaryrefslogtreecommitdiffstats
path: root/php-sebastian-recursion-context.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-07-26 19:14:42 +0200
committerRemi Collet <fedora@famillecollet.com>2015-07-26 19:14:42 +0200
commitc68032670d4cc6497a252fa18755a16ca94037ed (patch)
tree202739111430d3c263f3949d1fbd880984fda99a /php-sebastian-recursion-context.spec
parentb121c3fa02767976baed3971d8cd04203ed09f65 (diff)
php-sebastian-recursion-context: 1.0.1
Diffstat (limited to 'php-sebastian-recursion-context.spec')
-rw-r--r--php-sebastian-recursion-context.spec31
1 files changed, 17 insertions, 14 deletions
diff --git a/php-sebastian-recursion-context.spec b/php-sebastian-recursion-context.spec
index 9f1d55f..65eeb0e 100644
--- a/php-sebastian-recursion-context.spec
+++ b/php-sebastian-recursion-context.spec
@@ -1,4 +1,4 @@
-# spec file for php-sebastian-recursion-context
+# remirepo/fedora spec file for php-sebastian-recursion-context
#
# Copyright (c) 2015 Remi Collet
# License: CC-BY-SA
@@ -7,11 +7,11 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 3989662bbb30a29d20d9faa04a846af79b276252
+%global gh_commit 994d4a811bafe801fb06dccbee797863ba2792ba
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project recursion-context
-%global php_home %{_datadir}/php/SebastianBergmann
+%global php_home %{_datadir}/php
%if %{bootstrap}
%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
%else
@@ -19,21 +19,23 @@
%endif
Name: php-sebastian-recursion-context
-Version: 1.0.0
+Version: 1.0.1
Release: 1%{?dist}
Summary: Recursively process PHP variables
Group: Development/Libraries
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}.tar.gz
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php(language) >= 5.3.3
BuildRequires: %{_bindir}/phpab
%if %{with_tests}
-BuildRequires: %{_bindir}/phpunit
+# from composer.json, "require-dev": {
+# "phpunit/phpunit": "~4.4"
+BuildRequires: php-composer(phpunit/phpunit) >= 4.4
%endif
# from composer.json
@@ -61,16 +63,14 @@ phpab --output src/autoload.php src
%install
rm -rf %{buildroot}
-mkdir -p %{buildroot}%{php_home}
-cp -pr src %{buildroot}%{php_home}/RecursionContext
+mkdir -p %{buildroot}%{php_home}/SebastianBergmann
+cp -pr src %{buildroot}%{php_home}/SebastianBergmann/RecursionContext
%check
%if %{with_tests}
-phpunit \
- --include-path %{buildroot}%{_datadir}/php \
- --bootstrap %{buildroot}%{php_home}/RecursionContext/autoload.php \
- tests
+%{_bindir}/php -d include_path=.:%{buildroot}%{php_home}:%{php_home} \
+%{_bindir}/phpunit --bootstrap %{buildroot}%{php_home}/SebastianBergmann/RecursionContext/autoload.php
%else
: bootstrap build with test suite disabled
%endif
@@ -85,10 +85,13 @@ rm -rf %{buildroot}
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc README.md composer.json
-%dir %{php_home}
-%{php_home}/RecursionContext
+%dir %{php_home}/SebastianBergmann
+ %{php_home}/SebastianBergmann/RecursionContext
%changelog
+* Sun Jul 26 2015 Remi Collet <remi@fedoraproject.org> - 1.0.1-1
+- update to 1.0.1 (only CS)
+
* Sat Jan 24 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
- initial package \ No newline at end of file