summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-03-19 13:56:55 +0100
committerRemi Collet <remi@remirepo.net>2021-03-19 13:56:55 +0100
commitde9e20ac6b7bba6f6c83653a9f17768be5734865 (patch)
tree7a351b63b006b979dd6884f847b55731a27563a0
parentdaa3cc18618643fd3b03278277af26b44563f964 (diff)
spec cleanupHEADmaster
-rw-r--r--.gitignore9
-rw-r--r--php-sebastian-recursion-context.spec55
2 files changed, 27 insertions, 37 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/php-sebastian-recursion-context.spec b/php-sebastian-recursion-context.spec
index 9073d6b..fad5304 100644
--- a/php-sebastian-recursion-context.spec
+++ b/php-sebastian-recursion-context.spec
@@ -1,41 +1,35 @@
# remirepo/fedora spec file for php-sebastian-recursion-context
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global bootstrap 0
%global gh_commit 2c3ba150cbec723aa057506e73a8d33bdb286c9a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project recursion-context
%global php_home %{_datadir}/php
-%if %{bootstrap}
-%global with_tests %{?_with_tests:1}%{!?_with_tests:0}
-%else
-%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
-%endif
+
+%bcond_without tests
Name: php-sebastian-recursion-context
Version: 2.0.0
-Release: 1%{?dist}
+Release: 11%{?dist}
Summary: Recursively process PHP variables
-Group: Development/Libraries
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php(language) >= 5.3.3
BuildRequires: php-fedora-autoloader-devel
-%if %{with_tests}
+%if %{with tests}
# from composer.json, "require-dev": {
# "phpunit/phpunit": "~4.4"
-BuildRequires: php-composer(phpunit/phpunit) >= 4.4
+BuildRequires: phpunit
%endif
# from composer.json
@@ -63,44 +57,28 @@ phpab --template fedora --output src/autoload.php src
%install
-rm -rf %{buildroot}
mkdir -p %{buildroot}%{php_home}/SebastianBergmann
cp -pr src %{buildroot}%{php_home}/SebastianBergmann/RecursionContext
%check
-%if %{with_tests}
-: Run upstream test suite
-# remirepo:13
-run=0
+%if %{with tests}
ret=0
-if which php56; then
- php56 -d include_path=.:%{buildroot}%{_datadir}/php:%{_datadir}/php \
- %{_bindir}/phpunit --bootstrap %{buildroot}%{php_home}/SebastianBergmann/RecursionContext/autoload.php || ret=1
- run=1
-fi
-if which php71; then
- php71 -d include_path=.:%{buildroot}%{_datadir}/php:%{_datadir}/php \
- %{_bindir}/phpunit --bootstrap %{buildroot}%{php_home}/SebastianBergmann/RecursionContext/autoload.php || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/php -d include_path=.:%{buildroot}%{_datadir}/php:%{_datadir}/php \
-%{_bindir}/phpunit --bootstrap %{buildroot}%{php_home}/SebastianBergmann/RecursionContext/autoload.php --verbose
-# remirepo:2
-fi
+: Run upstream test suite
+for cmd in php php73 php74 php80; do
+ if which $cmd; then
+ $cmd -d include_path=.:%{buildroot}%{_datadir}/php:%{_datadir}/php \
+ %{_bindir}/phpunit --bootstrap %{buildroot}%{php_home}/SebastianBergmann/RecursionContext/autoload.php --verbose || ret=1
+ fi
+done
exit $ret
%else
: bootstrap build with test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc README.md composer.json
@@ -109,6 +87,9 @@ rm -rf %{buildroot}
%changelog
+* Fri Mar 19 2021 Remi Collet <remi@fedoraproject.org> - 2.0.0-11
+- spec cleanup
+
* Tue Nov 22 2016 Remi Collet <remi@fedoraproject.org> - 2.0.0-1
- update to 2.0.0 (no change)