summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-09-28 10:32:06 +0200
committerRemi Collet <remi@remirepo.net>2020-09-28 10:32:06 +0200
commitfaf6b6cc78bdfe09c0765b828774bbdfcfebb187 (patch)
treeb4dcc18a80573137b9bcfe5f81d000e0b91ab480
parent3afde3f007eaf54dcd02d070f2bbb98a2fc37957 (diff)
update to 2.0.3 (no change)
-rw-r--r--composer.json4
-rw-r--r--php-sebastian-object-reflector2.spec24
2 files changed, 14 insertions, 14 deletions
diff --git a/composer.json b/composer.json
index 3950a61..36a3378 100644
--- a/composer.json
+++ b/composer.json
@@ -18,10 +18,10 @@
"sort-packages": true
},
"require": {
- "php": "^7.3 || ^8.0"
+ "php": ">=7.3"
},
"require-dev": {
- "phpunit/phpunit": "^9.0"
+ "phpunit/phpunit": "^9.3"
},
"autoload": {
"classmap": [
diff --git a/php-sebastian-object-reflector2.spec b/php-sebastian-object-reflector2.spec
index cd43e15..b37b938 100644
--- a/php-sebastian-object-reflector2.spec
+++ b/php-sebastian-object-reflector2.spec
@@ -6,8 +6,10 @@
#
# Please, preserve the changelog entries
#
-%global bootstrap 0
-%global gh_commit 127a46f6b057441b201253526f81d5406d6c7840
+
+%bcond_without tests
+
+%global gh_commit d9d0ab3b12acb1768bc1e0a89b23c90d2043cbe5
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project object-reflector
@@ -19,16 +21,11 @@
%global ns_project ObjectReflector
%global major 2
%global php_home %{_datadir}/php
-%if %{bootstrap}
-%bcond_with tests
-%else
-%bcond_without tests
-%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 2.0.2
+Version: 2.0.3
Release: 1%{?dist}
-Summary: Allows reflection of object attributes
+Summary: Allows reflection of object attributes, version %{major}
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -40,12 +37,12 @@ BuildRequires: php(language) >= 7.3
BuildRequires: php-fedora-autoloader-devel
%if %{with tests}
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^9.0"
-BuildRequires: phpunit9
+# "phpunit/phpunit": "^9.3"
+BuildRequires: phpunit9 >= 9.3
%endif
# from composer.json
-# "php": "^7.3 || ^8.0"
+# "php": ">=7.3"
Requires: php(language) >= 7.3
# from phpcompatinfo report for version 2.0.0
Requires: php-spl
@@ -106,6 +103,9 @@ exit $ret
%changelog
+* Mon Sep 28 2020 Remi Collet <remi@remirepo.net> - 2.0.3-1
+- update to 2.0.3 (no change)
+
* Mon Jun 29 2020 Remi Collet <remi@remirepo.net> - 2.0.2-1
- update to 2.0.2