summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json2
-rw-r--r--php-sebastian-lines-of-code2.spec21
2 files changed, 15 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index e642bdb..1f3b747 100644
--- a/composer.json
+++ b/composer.json
@@ -18,7 +18,7 @@
"prefer-stable": true,
"require": {
"php": ">=8.1",
- "nikic/php-parser": "^4.10"
+ "nikic/php-parser": "^4.18 || ^5.0"
},
"require-dev": {
"phpunit/phpunit": "^10.0"
diff --git a/php-sebastian-lines-of-code2.spec b/php-sebastian-lines-of-code2.spec
index 65fef3c..c364ea9 100644
--- a/php-sebastian-lines-of-code2.spec
+++ b/php-sebastian-lines-of-code2.spec
@@ -10,7 +10,7 @@
%bcond_without tests
# github
-%global gh_commit 649e40d279e243d985aa8fb6e74dd5bb28dc185d
+%global gh_commit 856e7f6a75a84e339195d48c556f23be2ebf75d0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project lines-of-code
@@ -24,7 +24,7 @@
%global ns_project LinesOfCode
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 2.0.1
+Version: 2.0.2
Release: 1%{?dist}
Summary: Counting the lines of code in PHP source code, version %{major}
@@ -38,10 +38,10 @@ BuildArch: noarch
BuildRequires: php(language) >= 8.1
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(nikic/php-parser) >= 4.10 with php-composer(nikic/php-parser) < 5)
+BuildRequires: (php-composer(nikic/php-parser) >= 4.18 with php-composer(nikic/php-parser) < 6)
# remirepo:3
%else
-BuildRequires: php-nikic-php-parser4 >= 4.10
+BuildRequires: php-nikic-php-parser4 >= 4.18
%endif
BuildRequires: php-spl
# Autoloader
@@ -58,10 +58,10 @@ BuildRequires: phpunit10
Requires: php(language) >= 8.1
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(nikic/php-parser) >= 4.10 with php-composer(nikic/php-parser) < 5)
+Requires: (php-composer(nikic/php-parser) >= 4.18 with php-composer(nikic/php-parser) < 6)
# remirepo:3
%else
-Requires: php-nikic-php-parser4 >= 4.10
+Requires: php-nikic-php-parser4 >= 4.18
%endif
# from phpcompatinfo report for version 2.0.0
Requires: php-spl
@@ -89,7 +89,10 @@ phpab --template fedora --output src/autoload.php src
cat <<EOF | tee -a src/autoload.php
\Fedora\Autoloader\Dependencies::required([
- '%{php_home}/PhpParser4/autoload.php',
+ [
+ '%{php_home}/PhpParser5/autoload.php',
+ '%{php_home}/PhpParser4/autoload.php',
+ ],
]);
EOF
@@ -129,6 +132,10 @@ exit $ret
%changelog
+* Thu Dec 21 2023 Remi Collet <remi@remirepo.net> - 2.0.2-1
+- update to 2.0.2
+- raise dependency on nikic/php-parser 4.18 and allow 5.0
+
* Thu Aug 31 2023 Remi Collet <remi@remirepo.net> - 2.0.1-1
- update to 2.0.1