summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-08-23 15:22:50 +0200
committerRemi Collet <remi@php.net>2023-08-23 15:22:50 +0200
commiteb901a338bd08ca3f24ccf96e92896fecd999557 (patch)
tree384f82b86a4b594f599001278a3225a1f3b600cf
parent84eaa021616644b22828530f234c7d167d4a7596 (diff)
Enable test suite
-rw-r--r--php-sebastian-lines-of-code2.spec16
1 files changed, 11 insertions, 5 deletions
diff --git a/php-sebastian-lines-of-code2.spec b/php-sebastian-lines-of-code2.spec
index e90feb6..a068315 100644
--- a/php-sebastian-lines-of-code2.spec
+++ b/php-sebastian-lines-of-code2.spec
@@ -7,8 +7,7 @@
# Please, preserve the changelog entries
#
-# disabled until phpunit10 available
-%bcond_with tests
+%bcond_without tests
# github
%global gh_commit 17c4d940ecafb3d15d2cf916f4108f664e28b130
@@ -26,8 +25,8 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Version: 2.0.0
-Release: 1%{?dist}
-Summary: Counting the lines of code in PHP source code
+Release: 3%{?dist}
+Summary: Counting the lines of code in PHP source code, version %{major}
License: BSD-3-Clause
URL: https://github.com/%{gh_owner}/%{gh_project}
@@ -75,6 +74,10 @@ Provides: php-composer(%{pk_vendor}/%{pk_project}) = %{version}
%description
Library for counting the lines of code in PHP source code.
+This package provides version %{major} of %{pk_vendor}/%{pk_project} library.
+
+Autoloader: %{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php
+
%prep
%setup -q -n %{gh_project}-%{gh_commit}
@@ -103,7 +106,7 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php php81 php82; do
+for cmd in php php81 php82 php83; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
%{_bindir}/phpunit10 || ret=1
@@ -126,6 +129,9 @@ exit $ret
%changelog
+* Wed Aug 23 2023 Remi Collet <remi@remirepo.net> - 2.0.0-3
+- Enable test suite
+
* Fri Feb 3 2023 Remi Collet <remi@remirepo.net> - 2.0.0-1
- update to 2.0.0
- raise dependency on PHP 8.1