summaryrefslogtreecommitdiffstats
path: root/php-sebastian-global-state6.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-sebastian-global-state6.spec')
-rw-r--r--php-sebastian-global-state6.spec9
1 files changed, 2 insertions, 7 deletions
diff --git a/php-sebastian-global-state6.spec b/php-sebastian-global-state6.spec
index a93079d..25eb5de 100644
--- a/php-sebastian-global-state6.spec
+++ b/php-sebastian-global-state6.spec
@@ -1,4 +1,4 @@
-# spec file for php-sebastian-global-state5
+# spec file for php-sebastian-global-state6
#
# Copyright (c) 2014-2023 Remi Collet
# License: CC-BY-SA-4.0
@@ -116,18 +116,13 @@ require_once 'tests/autoload.php';
require_once 'tests/_fixture/SnapshotFunctions.php';
EOF
-# testInterfaces and testConstructorExcludesAspectsWhenTheyShouldNotBeIncluded
-# mays fails locally with psr extension
-# testCanExportGlobalVariablesToCode, testStaticNotInitialisedAttributes temporarily fails (use old version ?)
-
: Run upstream test suite
ret=0
for cmd in php php81 php82; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
%{_bindir}/phpunit10 \
- --filter '^((?!(testConstructorExcludesAspectsWhenTheyShouldNotBeIncluded|testCanExportGlobalVariablesToCode|testStaticNotInitialisedAttributes)).)*$' \
- --verbose || ret=1
+ || ret=1
fi
done
exit $ret