summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json4
-rw-r--r--php-sebastian-exporter4.spec11
2 files changed, 9 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index b1515f3..c46d2a0 100644
--- a/composer.json
+++ b/composer.json
@@ -35,11 +35,11 @@
},
"prefer-stable": true,
"require": {
- "php": "^7.3",
+ "php": "^7.3 || ^8.0",
"sebastian/recursion-context": "^4.0"
},
"require-dev": {
- "phpunit/phpunit": "^9.0",
+ "phpunit/phpunit": "^9.2",
"ext-mbstring": "*"
},
"autoload": {
diff --git a/php-sebastian-exporter4.spec b/php-sebastian-exporter4.spec
index 76ef83b..9589445 100644
--- a/php-sebastian-exporter4.spec
+++ b/php-sebastian-exporter4.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit d12fbca85da932d01d941b59e4b71a0d559db091
+%global gh_commit 571d721db4aec847a0e59690b954af33ebf9f023
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project exporter
@@ -28,7 +28,7 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 4.0.1
+Version: 4.0.2
Release: 1%{?dist}
Summary: Export PHP variables for visualization
@@ -42,9 +42,9 @@ BuildRequires: php(language) >= 7.3
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
%if %{with_tests}
# from composer.json, "require-dev": {
-# "phpunit/phpunit": "^9.0",
+# "phpunit/phpunit": "^9.2",
# "ext-mbstring": "*"
-BuildRequires: phpunit9
+BuildRequires: phpunit9 >= 9.2
BuildRequires: php-mbstring
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -126,6 +126,9 @@ exit $ret
%changelog
+* Mon Jun 29 2020 Remi Collet <remi@remirepo.net> - 4.0.2-1
+- update to 4.0.2
+
* Tue Jun 16 2020 Remi Collet <remi@remirepo.net> - 4.0.1-1
- update to 4.0.1
- sources from git snapshot