summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-06-16 07:53:06 +0200
committerRemi Collet <remi@remirepo.net>2020-06-16 07:53:06 +0200
commit8f6064b5b4ead4a431fefbd9a75b9200dbc7f56f (patch)
tree6816c922976421013d785df28408e21688a6d2bc
parentd5583fb4e3dc546b3a1a2b3aafc98c287f5aa1b9 (diff)
update to 4.0.1
sources from git snapshot
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-sebastian-exporter4.spec18
2 files changed, 39 insertions, 7 deletions
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..4190c13
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs --exclude tools $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-sebastian-exporter4.spec b/php-sebastian-exporter4.spec
index d8b7344..76ef83b 100644
--- a/php-sebastian-exporter4.spec
+++ b/php-sebastian-exporter4.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 80c26562e964016538f832f305b2286e1ec29566
+%global gh_commit d12fbca85da932d01d941b59e4b71a0d559db091
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner sebastianbergmann
%global gh_project exporter
@@ -28,13 +28,14 @@
%endif
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 4.0.0
+Version: 4.0.1
Release: 1%{?dist}
Summary: Export PHP variables for visualization
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php(language) >= 7.3
@@ -43,8 +44,7 @@ BuildRequires: php-fedora-autoloader-devel >= 1.0.0
# from composer.json, "require-dev": {
# "phpunit/phpunit": "^9.0",
# "ext-mbstring": "*"
-# TODO test suite passes with v8, switch to v9 when available
-BuildRequires: phpunit8
+BuildRequires: phpunit9
BuildRequires: php-mbstring
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -106,10 +106,10 @@ touch vendor/autoload.php
: Run upstream test suite
ret=0
-for cmd in php php73 php74; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
$cmd -d auto_prepend_file=%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php \
- %{_bindir}/phpunit8 --verbose || ret=1
+ %{_bindir}/phpunit9 --verbose || ret=1
fi
done
exit $ret
@@ -126,6 +126,10 @@ exit $ret
%changelog
+* Tue Jun 16 2020 Remi Collet <remi@remirepo.net> - 4.0.1-1
+- update to 4.0.1
+- sources from git snapshot
+
* Fri Feb 7 2020 Remi Collet <remi@remirepo.net> - 4.0.0-1
- update to 4.0.0
- raise dependency on PHP 7.3